The Official Sequential/DSI Forum

Is it a MUST to upgrade OS from 2.3, voice 1.5 to the Beta OS...?

Is it significantly upgraded...?


Is the new Beta OS reliable and better from your experience?



Thanks in advance!