Take 5 stuck on start-up logo

Take 5 stuck on start-up logo
« on: August 10, 2023, 12:00:59 PM »

Has anyone experienced this issue before?
My Take 5 wonít boot up - itís just stuck on the TAKE 5 logo when I turn it on. I hadnít used it for days and it was simply sitting on my desk. It worked perfectly fine just now when it froze all of a sudden and none of the controls or keys worked. When I powered it off and on it started freezing like this. Very strange.

I bought it used three weeks ago. Still paid a lot for it. When I got it I played it for several days and even recorded with it just fine, no issues whatsoever.

I have written to support.
I also found a thread where it had happened to other users - https://forum.sequential.com/index.php?topic=6033.0

One guy got his unit entirely replaced and another got a main board sent from Sequential to install himself, and it started working again. Does this mean that installing a new main board would be a surefire way to effectively renew the synth? Without the hassle of returning the unit. Is it just a main board issue? I still have a 3-year warranty on it.  The previous owner sent me the invoice.

Iím pretty bummed rn 😐

Re: Take 5 stuck on start-up logo
« Reply #1 on: August 10, 2023, 01:45:23 PM »
Saw your post on Reddit about this, too, and again, I'm sure Sequential Support will take care of you, but I did have a thought -- is your T5 connected via USB or MIDI right now? If it is, what happens if you try to power-up while those connections are no longer plugged-in?

Re: Take 5 stuck on start-up logo
« Reply #2 on: August 10, 2023, 01:48:28 PM »
Saw your post on Reddit about this, too, and again, I'm sure Sequential Support will take care of you, but I did have a thought -- is your T5 connected via USB or MIDI right now? If it is, what happens if you try to power-up while those connections are no longer plugged-in?

Hey, no I havenít used those features at all. It only has the power cable inserted, I press ON and the logo comes on and stays that way. Nothing else happening
« Last Edit: August 10, 2023, 01:50:32 PM by Realeyes »

Re: Take 5 stuck on start-up logo
« Reply #3 on: August 10, 2023, 04:37:28 PM »
Update: Just heard back from support. They offered me a new main PCB, and the swapping is supposed to be a simple process. Great news, and I'm relieved. What a great support team.

Re: Take 5 stuck on start-up logo
« Reply #4 on: August 10, 2023, 07:20:56 PM »
Update: Just heard back from support. They offered me a new main PCB, and the swapping is supposed to be a simple process. Great news, and I'm relieved. What a great support team.

Glad to hear it -- I've had mine open and it does look like an easy swap. Hope you're back in action shortly.