problems while loading patches

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
problems while loading patches
« on: January 13, 2023, 04:37:59 PM »
Hi, I installed the last beta OS 1.0.0.22, in order to have more patch memories, etc.

before I backed up my user patches, then I managed my patches differently, on the 16 user banks available now, and made a backup of these. No problems, but after I tried other adjustments, reloaded my initial (128 user) backup to transfer to factory patches (it's possible via Debug menu), then reloaded my 256 user patches backup :
I experiment problems, some patches don't return to the Take 5.

I'm using Midi Ox, when sending my patches via sysex to the Take 5, they always stop at 504, then jump to 601 and stop at 608, and stay there. I've observed (when retrying multiple times) that if I touch buttons or wheels of the T5 during uploading, it will accept some more patches than getting stuck to the 608. Forgot to tell that obviously I lost the patches when the process stops (they become basic patches)

Is it a problem with Midi Ox, or due to the new OS, or are my backup files faulty ?

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #1 on: January 18, 2023, 04:36:31 PM »
I precise that I transfer the sysex via Take 5's usb midi (not the midi din input/output)

Re: problems while loading patches
« Reply #2 on: January 19, 2023, 01:35:21 PM »
In MIDI-Ox Sysex Config, there's a setting for "Delay after F7"...   If you haven't already, try increasing that to around 1000-1500 milliseconds.   This will slow down the sending of patches, and give the T5 more time to process and save each patch/packet.

https://www.presetpatch.com/articles/Sending-Sysex-Patch-Files-to-Your-Instrument


Hi, I installed the last beta OS 1.0.0.22, in order to have more patch memories, etc.

before I backed up my user patches, then I managed my patches differently, on the 16 user banks available now, and made a backup of these. No problems, but after I tried other adjustments, reloaded my initial (128 user) backup to transfer to factory patches (it's possible via Debug menu), then reloaded my 256 user patches backup :
I experiment problems, some patches don't return to the Take 5.

I'm using Midi Ox, when sending my patches via sysex to the Take 5, they always stop at 504, then jump to 601 and stop at 608, and stay there. I've observed (when retrying multiple times) that if I touch buttons or wheels of the T5 during uploading, it will accept some more patches than getting stuck to the 608. Forgot to tell that obviously I lost the patches when the process stops (they become basic patches)

Is it a problem with Midi Ox, or due to the new OS, or are my backup files faulty ?


Sequential Pro 3, Prophet Rev2, Deepmind, PolyBrute, Sub 37
Sound Sets on Sellfy:
https://sounddesign.sellfy.store/
Free Patches:
https://www.PresetPatch.com/user/CreativeSpiral

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #3 on: January 20, 2023, 04:28:03 PM »
thanks for this tip, I will try this

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #4 on: January 22, 2023, 02:19:27 PM »
I've tried these settings for delay after F7 (1500 milliseconds, then 1000 ms), but the transfer still stucks at the same moments...

I'm wondering if my backups had a problem when I done them, or if the Take 5 lacks of memory ? Tell this because I've discovered this website :https://www.presetpatch.com/synth/Sequential-Take-5
it allows to send or receive sysex online. While I was trying to send sysex (forgot to close Midi-Ox), I saw a message that the Take 5 didn't have enough memory...

Re: problems while loading patches
« Reply #5 on: January 23, 2023, 09:13:25 AM »
Hmm..  yeah, you might just have a bad backup file (or incomplete file).

If you want to send your patch backup .syx file over, I can take a quick look at it and tell you if it seems like it's valid/complete.   You can attach it here, upload, or PM me.


Sequential Pro 3, Prophet Rev2, Deepmind, PolyBrute, Sub 37
Sound Sets on Sellfy:
https://sounddesign.sellfy.store/
Free Patches:
https://www.PresetPatch.com/user/CreativeSpiral

Re: problems while loading patches
« Reply #6 on: January 23, 2023, 09:34:14 AM »
Are you using one of these MIDI interfaces that have been identified by Sequential as being problematic?

    Native Instruments Maschine
    Digidesign Mbox/Mbox2
    Digidesign 001/002
    CME U2MIDI



doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #7 on: January 23, 2023, 01:03:29 PM »
Hmm..  yeah, you might just have a bad backup file (or incomplete file).

If you want to send your patch backup .syx file over, I can take a quick look at it and tell you if it seems like it's valid/complete.   You can attach it here, upload, or PM me.

thanks very much, I'll soon send you my sysex files

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #8 on: January 23, 2023, 01:05:43 PM »
Are you using one of these MIDI interfaces that have been identified by Sequential as being problematic?

    Native Instruments Maschine
    Digidesign Mbox/Mbox2
    Digidesign 001/002
    CME U2MIDI

I don't use any soundcard, as I added on reply #1 : I transfer the sysex via Take 5's usb midi (not the midi din input/output)

Re: problems while loading patches
« Reply #9 on: January 23, 2023, 02:35:45 PM »
Are you using one of these MIDI interfaces that have been identified by Sequential as being problematic?

    Native Instruments Maschine
    Digidesign Mbox/Mbox2
    Digidesign 001/002
    CME U2MIDI

I don't use any soundcard, as I added on reply #1 : I transfer the sysex via Take 5's usb midi (not the midi din input/output)

Doh! And I actually remember you writing that, too. sigh

Do you still have the problem if your USB connection is direct to your host, if it isn't already?

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #10 on: January 24, 2023, 04:39:28 AM »
tried to upload my sysex backup on PresetPatch, returned this message :
"Must be Valid Sysex Bytes to Save ( 180)"

and "Must be Valid Sysex Bytes to Save ( 173)" with another bakcup (made 2 different)

So there was a problem while backing up with Midi Ox,
maybe a problem with the Take 5's usb connexion ?

Re: problems while loading patches
« Reply #11 on: January 24, 2023, 10:01:26 AM »
tried to upload my sysex backup on PresetPatch, returned this message :
"Must be Valid Sysex Bytes to Save ( 180)"

and "Must be Valid Sysex Bytes to Save ( 173)" with another bakcup (made 2 different)

So there was a problem while backing up with Midi Ox,
maybe a problem with the Take 5's usb connexion ?

Hmm.. yeah, sounds like invalid/incomplete sysex being sent/received.   As mentioned in PM, if you have the original saved .syx  file and want to email me with attachment, I can check that out and let you know for sure.   

It might be something to do with T5 USB ... Probably best to contact support, and they can help you debug further... https://www.sequential.com/support/contact-support/


Sequential Pro 3, Prophet Rev2, Deepmind, PolyBrute, Sub 37
Sound Sets on Sellfy:
https://sounddesign.sellfy.store/
Free Patches:
https://www.PresetPatch.com/user/CreativeSpiral

Re: problems while loading patches
« Reply #12 on: January 24, 2023, 02:38:27 PM »
tried to upload my sysex backup on PresetPatch, returned this message :
"Must be Valid Sysex Bytes to Save ( 180)"

and "Must be Valid Sysex Bytes to Save ( 173)" with another bakcup (made 2 different)

So there was a problem while backing up with Midi Ox,
maybe a problem with the Take 5's usb connexion ?

Hmm.. yeah, sounds like invalid/incomplete sysex being sent/received.   As mentioned in PM, if you have the original saved .syx  file and want to email me with attachment, I can check that out and let you know for sure.   

It might be something to do with T5 USB ... Probably best to contact support, and they can help you debug further... https://www.sequential.com/support/contact-support/

Fwiw I'm able to save and accept sysex patches and banks using the T5 USB connection both with Logic and SysEx Librarian on the Mac with the .22 beta.

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #13 on: January 25, 2023, 04:38:18 PM »
I'm on PC, perhaps errors appeared during the backups ? But I made 2 different (one with 128 patches, another with 256).
When I restore each one (tried several times) my Take 5 stops at the same patches numbers and some patches lost

Re: problems while loading patches
« Reply #14 on: January 26, 2023, 09:30:52 AM »
I'm on PC, perhaps errors appeared during the backups ? But I made 2 different (one with 128 patches, another with 256).
When I restore each one (tried several times) my Take 5 stops at the same patches numbers and some patches lost

Hey - I got a chance to analyze the two files you emailed me.  Both of them have corrupt sysex packets / bytes in them.  That's why they were not accepted on PresetPatch.com.   Between the F0 (opening) and F7 (closing) bytes for each packet, only values of 00-7F are valid (0-127).   In both the files there were other hex bytes larger than the 127 value... ie: A4 = 164, which is an invalid sysex byte.   Also, there appeared to be some other incomplete F0...F7 packets.   I spent a few minutes just manually trying to cleanup/remove bad packets from the 256 one... will reply to your email / send that back to you.  You can try it / see if you get better results... though, I can't guarantee it will work, and there will be some packets/patches missing.  I just fixed what I could easily see was corrupted in a text editor... there may be more issues.   

As far as why this might have happened... I'm not sure... though Sysex transfers are notoriously fickle.  It's always best to make sure no other devices are hooked up, no MIDI clock running, and don't press any keys or move any controls while the process is occurring.   Whenever I'm doing a big backup for one of my instruments, I usually do it twice, then compare the two files and make sure they match.


Sequential Pro 3, Prophet Rev2, Deepmind, PolyBrute, Sub 37
Sound Sets on Sellfy:
https://sounddesign.sellfy.store/
Free Patches:
https://www.PresetPatch.com/user/CreativeSpiral

doudou26

  • *
  • 12
  • owner of a Prophet 6 and a Take 5
Re: problems while loading patches
« Reply #15 on: January 26, 2023, 03:52:17 PM »
thanks for the time spent at the analyse and cleaning of the file,
may try it sunday.

Before buying two Sequential synths, I had several Roland Boutique (Jp-08, Ju-06a and Sh-01a), the backups were very simple via usb. Just had to copy the folder, these Roland synths act like a usb key, no sysex to manage.