The Official Sequential/DSI Forum

New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)

Hello all,
I got my new PRO3 today and the following MIDI problems have appeared (firmware 1.1.2.8 is installed):

- MIDI via USB does not work at all (I tried different cables and 2 different PCs, global settings reset several times and each time set correctly.

- MIDI via 5-pin MIDI cable works. Tried to install the firmware "Main 1.2.0.2" with MIDI-OX. The export of the Sysex file worked, the PRO3 has "installed" to 100%, then immediately the last program was displayed again. Have then switched power off and on again, but the synth was still at 1.1.2.8.
Repeated it again, with the same result.

What can I have done wrong?
Thanks for any advice!

JayT

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #1 on: July 23, 2021, 12:42:43 PM »
Did you go through every step described in the update Description?
https://forum.sequential.com/index.php?action=dlattach;topic=5201.0;attach=3661

I had no issues with this update via USB using MidiOx (open, buffer size, sysx, load, send, wait until it tells you to power off).

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #2 on: July 23, 2021, 10:35:09 PM »
Did you go through every step described in the update Description?
https://forum.sequential.com/index.php?action=dlattach;topic=5201.0;attach=3661

I had no issues with this update via USB using MidiOx (open, buffer size, sysx, load, send, wait until it tells you to power off).

Yes, actually step by stepÖ

- I can see the progress on the PC while transferring the sysex data.
- There is this status message in the Pro3 display "receiving operating system" and the number counting from 0% to 100%.
But after that nothing happens or is shown anymore. The Synth just returns to the state (program) before starting the transfer. No black screen, no messages. Stil the same firmware as before. Iíve just tried it now after having booted/started everything again.

JayT

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #3 on: July 24, 2021, 02:04:03 AM »
Ok, that is strange. I'd contact sequential support.

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #4 on: July 24, 2021, 02:22:02 AM »
Ok, that is strange. I'd contact sequential support.

Thanks for your feedback and help. I'll check for some days and contact the dealer (and there's a full 30 day money back guarantee). But it seems that this item is a bit faulty...

JayT

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #5 on: July 24, 2021, 03:40:32 AM »
I'd give sequential support a try. They are very good and helpful and may safe some of your time waiting for a new device. Especially when it comes to software issues.

In the meantime there are plenty of things to try without the newest version.

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #6 on: July 24, 2021, 03:55:29 AM »
I'd give sequential support a try. They are very good and helpful and may safe some of your time waiting for a new device. Especially when it comes to software issues.

In the meantime there are plenty of things to try without the newest version.

Thanks! And yes, thereís much to discover indeed! I canít decide which one of the filters I like most  ;D

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #7 on: July 24, 2021, 05:36:02 AM »
I've just tried again to update the firmware - and it actually worked! Don't know why, because I didn't change anything...

Anyway, one problem solved (but I've already noticed some others beside of USB MIDI not working).

Re: New PRO3 user - 2 MIDI problems (no USB-MIDI, FW update impossible)
« Reply #8 on: July 24, 2021, 07:35:24 AM »
I've just tried again to update the firmware - and it actually worked! Don't know why, because I didn't change anything...

Anyway, one problem solved (but I've already noticed some others beside of USB MIDI not working).

Edit: MIDI via USB seems to work after the FW update as well, but not 100%, e.g. Controller data (pitch/mod wheel or aftertouch) still aren't transmitted via USB, only via 5-pol MIDI. Also at one point the slider touch stripe went "mad" and the latch function didn't work properly. After unplugging the USB cable from the back and restarting it worked fine again. I'm afraid there's a major issue with the USB function (hardware and/or software). I'll talk to the dealer next week.

On the other hand the PRO 3 sounds amazing! I'm an old school guy and love the sound of the analog oscillators - very moogish (oops - am I allowed to say this here - LOL!). I had a Voyager Old School once and am very pleased that the PRO 3 is able to sound very similar (and of course beyond).