The Official Sequential/DSI Forum

NOT WORKING - Update from 1.5.5 to 1.6.6

NOT WORKING - Update from 1.5.5 to 1.6.6
« on: February 26, 2021, 04:44:16 PM »
I've tried everything. Midi, USB hub, USB from MAC. Anything and always boots to 1.5.5.
Earlier version

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #1 on: February 27, 2021, 09:15:10 AM »
Same here. Tried MIDI, USB, two different interfaces, two different computer, and bootloader mode. First countdown completes, but the second countdown never happens and the synth just reboots.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #2 on: February 27, 2021, 09:36:00 AM »
Same here, always after the countdown restarts in 1.5.5. .

Maybe if I could install an earlier version before 1.5.5 first, but they are not available for download anymore.

Hope Sequential will find a solution for this, because you are not the only ones having this issue.

Greetings Benny.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #3 on: February 27, 2021, 09:45:02 AM »
After two hours of trial and error with different interfaces, operating systems, and buffer values, I finally found a combination that worked:

1. Only update in bootloader mode over MIDI. Updating in normal mode over either MIDI or USB always fails.

2. I used buffer size 1024 and buffer number 1024 in MIDI-OX. These may be different for your MIDI interface.

3. I used my MOTU MTP AV USB interface. Other interfaces I tried resulted in "out of memory" errors in MIDI-OX.

IMPORTANT: MIDI-OX will finish sending the update file way faster than the countdown from 999 progresses. Wait for the countdown to finish, it takes about 6-7 minutes. Then, if Dave Smith decides to bless your synth at that very moment, you'll see the second countdown from 8 to 0 and then the synth reboots to 1.6.6.

Hope this helps someone.
« Last Edit: February 27, 2021, 09:48:47 AM by siraltus »

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #4 on: February 27, 2021, 12:36:05 PM »
Does somebody know if the recent official 1.6.6 version is the same one as beta 1.6.6?

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #5 on: February 27, 2021, 12:50:53 PM »
Thank you! After multiple attempts (with and without boot loader), I setup the same buffer size config (albeit using SysEx Librarian on a Mac) and that did the trick.

After two hours of trial and error with different interfaces, operating systems, and buffer values, I finally found a combination that worked:

1. Only update in bootloader mode over MIDI. Updating in normal mode over either MIDI or USB always fails.

2. I used buffer size 1024 and buffer number 1024 in MIDI-OX. These may be different for your MIDI interface.

3. I used my MOTU MTP AV USB interface. Other interfaces I tried resulted in "out of memory" errors in MIDI-OX.

IMPORTANT: MIDI-OX will finish sending the update file way faster than the countdown from 999 progresses. Wait for the countdown to finish, it takes about 6-7 minutes. Then, if Dave Smith decides to bless your synth at that very moment, you'll see the second countdown from 8 to 0 and then the synth reboots to 1.6.6.

Hope this helps someone.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #6 on: March 01, 2021, 10:48:57 AM »
Hello siraltus,

thanks for the great tip.

First I tried to install an earlier version but no luck the OB 6 always restarts in 1.5.5.
There must be an error in 1.5.5 that prevents you from installing any update if the OB 6 isn't in boot loader mode and midi connected.
Midi-OX did also stated not enough memory a lot of times when trying different buffer sizes which froze the update on random countdown numbers.
When no memory error occurred and midi-OX is sending the sysex file too fast the update also got stuck on random countdown numbers depending on the buffer size I chose!

And finally Dave Smith like you said blessed my OB 6 restarting in 1.6.6 .

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #7 on: March 01, 2021, 11:06:19 AM »
Thank you! After multiple attempts (with and without boot loader), I setup the same buffer size config (albeit using SysEx Librarian on a Mac) and that did the trick.

What buffer size did you set in Sysex Librarian? The highest buffer size I see is 256. Thanks!

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #8 on: March 01, 2021, 12:11:58 PM »
Turns out the default buffer size in Sysex Librarian works fine. =)

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #9 on: March 01, 2021, 09:55:47 PM »
Having the same problem. Sorry to be a noob, but how do you put OB-6 into Bootloader mode? There is no way to search this forum (a major oversight, IMHO).

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #10 on: March 01, 2021, 10:49:02 PM »
Turn the OB-6 while pressing Write

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #11 on: March 02, 2021, 10:29:25 PM »
Thanks for the help - did get it working finally. I wish Sequential would just acknowledge that this update WILL NOT WORK unless you use MIDI, not USB, and put the OB-6 into Bootloader mode before you start the update.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #12 on: March 03, 2021, 03:33:03 AM »
The update worked for me with USB

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #13 on: March 04, 2021, 05:50:48 PM »
Sorry mates, but this is all  BS.  It should definitely not be this hard to perform an OS update.  Reading all the posts in this thread demonstrates to me that there has to be a specific set of circumstances (midi, no USB, write mode, etc.) that was unanticipated by Sequential.  I just sent them my feedback on this topic after spending two hours trying everything mentioned, using a Mac, in write mode, over midi, over USB, using multiple Macs and PCs, and nothing has worked.  Even those who have had success, there must me something different that the rest of us are struggling with.  This is why beta versions are released, and issues need to be addressed prior to formal release of a new OS.  I am sure Sequential is aware and are beating themselves up on why this is happening.  However, it's not quite to the standards that we expect from them or any other keyboard manufacturer.  We shouldn't have to be wasting our collective hours on trying to figure this out.  Be sure to send your feedback to Support on their website.  Not good !!

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #14 on: March 05, 2021, 05:56:12 AM »
It finally worked on mine, using bootloader mode via MIDI, and 512 buffer settings in MIDI-OX.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #15 on: March 12, 2021, 05:47:15 PM »
I just got my OB-6 today and am trying to install the update. I am in bootloader mode, set all the other things according to the instructions, and when sysex was sending the countdown was happening on the OB-6 effects A screen. Now midiox has stopped sending sysex and the OB-6 counter is frozen on 834. Should I keep waiting or what?

edit:
Waiting and the unit seems to get very warm. Is that normal? After 10 minutes or so I decided to turn it off. I tried again following the different advised methods here and it all only results in the counter freezing as soon as sysex is done sending. Then sit on that number and get warmer and warmer.This is not my favorite way to spend my first day with a new synth. Quite frankly, it's a hassle.
« Last Edit: March 12, 2021, 06:40:49 PM by Sorcerio »

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #16 on: March 12, 2021, 07:35:47 PM »
Ok. I just achieved success with installing the update. Now showing 1.6.6 upon power-up. My problem must have been tied to the audio/midi interface I was using. Steinberg UR22MKII. I just remembered that I had an old inline usb midi interface sitting in a box from the times of yore, MidiMan UNO. Downloaded and installed the drivers from M-Audio for that device, powered down the PC, disconnected my UR22MKII, made the connections, restarted the PC, and then commenced once again with the update process... lo and behold: it worked following the original steps in the txt contained with the update zip file!

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #17 on: March 12, 2021, 11:53:42 PM »
I find that the OB-6 gets warmer than most analogue synths I know, and needs to be pretty warm to be stable.
Mine does anyway.

I just got my OB-6 today and am trying to install the update. I am in bootloader mode, set all the other things according to the instructions, and when sysex was sending the countdown was happening on the OB-6 effects A screen. Now midiox has stopped sending sysex and the OB-6 counter is frozen on 834. Should I keep waiting or what?

edit:
Waiting and the unit seems to get very warm. Is that normal? After 10 minutes or so I decided to turn it off. I tried again following the different advised methods here and it all only results in the counter freezing as soon as sysex is done sending. Then sit on that number and get warmer and warmer.This is not my favorite way to spend my first day with a new synth. Quite frankly, it's a hassle.

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #18 on: March 14, 2021, 01:22:45 PM »
No luck here with USB update from iMac running Catalina and SysEx Librarian. Same result, counts down the file transfer properly but doesn't process the update and boots back into 1.5.5.

I don't have a MIDI interface, I have to use USB. So I guess I'm out of luck!

Re: NOT WORKING - Update from 1.5.5 to 1.6.6
« Reply #19 on: March 17, 2021, 10:48:00 AM »
No luck here with USB update from iMac running Catalina and SysEx Librarian. Same result, counts down the file transfer properly but doesn't process the update and boots back into 1.5.5.

I don't have a MIDI interface, I have to use USB. So I guess I'm out of luck!

Do you have a link here can I download it from? I just took delivery of an OB-6 and It's running version 1.5.5.