The Official Sequential/DSI Forum

Mac Big Sur MIDI Issue

Mac Big Sur MIDI Issue
« on: February 23, 2021, 06:01:43 AM »
Hey Fellow Rev2 Enthusiasts,

My Prophet 12 shows up on my iMac, my REV2 doesn't. I plugged my REV2 into my laptop and it shows up. Rules out any hardware problems with the REV2.

My iMac is not detecting the REV2 since upgrading to Big Sur. My laptop is still on Catalina, an older operating system.

Does anyone have a similar problem? Or, is your Big Sur operating system detecting your REV2 with no issues? How would one go about fixing this?

Thanks,

timboréale

  • **
  • 132
  • MIDI nerd
Re: Mac Big Sur MIDI Issue
« Reply #1 on: February 23, 2021, 06:08:57 AM »
Not a terribly useful data point here, but I'm also still on Catalina and have no issues connecting a Rev2 to a recent-model Intel Mac Mini, and I'm even using a USB-C to USB-A adapter and going through a nest of hubs. Have you tried changing cables, adapters, hubs, etc? I'm not aware of a Big-Sur-wide connectivity problem, so *most likely* it's something in your setup (USB cable may break internally when bent to fit the iMac but doesn't when it fits the laptop, etc).
Rev2-16, Prophet 12 Keyboard, Nords, etc...

Re: Mac Big Sur MIDI Issue
« Reply #2 on: February 23, 2021, 02:06:39 PM »
No issues here with Big Sur

Re: Mac Big Sur MIDI Issue
« Reply #3 on: February 24, 2021, 07:16:05 AM »
Not a terribly useful data point here, but I'm also still on Catalina and have no issues connecting a Rev2 to a recent-model Intel Mac Mini, and I'm even using a USB-C to USB-A adapter and going through a nest of hubs. Have you tried changing cables, adapters, hubs, etc? I'm not aware of a Big-Sur-wide connectivity problem, so *most likely* it's something in your setup (USB cable may break internally when bent to fit the iMac but doesn't when it fits the laptop, etc).

Thanks for chiming in! I did try the changing of the Cables. I think my Mac decided to lose my REV2 somehow, as indicated by the other user who faces no Big Sur issues.

Re: Mac Big Sur MIDI Issue
« Reply #4 on: February 24, 2021, 07:17:01 AM »
No issues here with Big Sur

Ahhh. Thanks for taking the time to write this. I could have probably deduced it from the lack of posts on the subject. Your confirmation, however, is generous and appreciated.

Thanks all.

timboréale

  • **
  • 132
  • MIDI nerd
Re: Mac Big Sur MIDI Issue
« Reply #5 on: February 24, 2021, 07:21:12 AM »
I don't have Big Sur handy, but one trick for funky MIDI issues is to unplug your MIDI devices (including the interface and all USB MIDI tidbits), go into the Audio Midi Setup application, open the MIDI Studio (command+2), and delete all of the devices you can - ensure that you can at least delete the Rev2. Then, reconnect everything and see if they all show back up. If they do, then the USB is recognizing it properly and it's an issue with the DAW. If they don't come back in the MIDI studio view, then the system is failing to see them as a MIDI object. Note that only devices with a native MIDI interface (e.g. USB) will show up - stuff connected to those interfaces via DIN will not, as they are just traffic on the interface from the OS's perspective.
Rev2-16, Prophet 12 Keyboard, Nords, etc...

Re: Mac Big Sur MIDI Issue
« Reply #6 on: February 25, 2021, 06:47:18 AM »
I don't have Big Sur handy, but one trick for funky MIDI issues is to unplug your MIDI devices (including the interface and all USB MIDI tidbits), go into the Audio Midi Setup application, open the MIDI Studio (command+2), and delete all of the devices you can - ensure that you can at least delete the Rev2. Then, reconnect everything and see if they all show back up. If they do, then the USB is recognizing it properly and it's an issue with the DAW. If they don't come back in the MIDI studio view, then the system is failing to see them as a MIDI object. Note that only devices with a native MIDI interface (e.g. USB) will show up - stuff connected to those interfaces via DIN will not, as they are just traffic on the interface from the OS's perspective.

Ummm.... that is super handy! I ran across this and it seemed to work, so I wanted to post it for anyone else! https://support.apple.com/guide/audio-midi-setup/if-a-connected-midi-device-isnt-shown-amsd0b13f5d9/mac