The Official Sequential/DSI Forum

Pro 3 USB - dead?

Pro 3 USB - dead?
« on: February 14, 2021, 09:41:29 AM »
Hi all

So, only months after my Prophet 6 USB seemingly dying on me, my P3 may have an issue :(

When connected by USB, my Mac OSX computer is not registering any incoming MIDI nor seeing the device in Sysex Librarian

My MIDI settings are such that I'm transmitting everything I can via USB, but are there any checks I can do before calling support again? SO frustrating!

Thanks

Re: Pro 3 USB - dead?
« Reply #1 on: February 19, 2021, 12:17:32 PM »
I had a usb cable that worked for years with my Prophet 6 not work with my Pro 3.  It still works with my Prophet 6, and I thought I had an issue with my Pro 3, but after trying a couple more cables one of them that's almost brand new works with both instruments every time perfectly.

I know it seems ridiculous, but I'd try a new usb cable, even if your cable works with other instruments.  It worked for me.

Re: Pro 3 USB - dead?
« Reply #2 on: February 22, 2021, 02:25:27 PM »
I had a usb cable that worked for years with my Prophet 6 not work with my Pro 3.  It still works with my Prophet 6, and I thought I had an issue with my Pro 3, but after trying a couple more cables one of them that's almost brand new works with both instruments every time perfectly.

I know it seems ridiculous, but I'd try a new usb cable, even if your cable works with other instruments.  It worked for me.

No, not ridiculous at all and I did try that to no avail. Several USB cables!

I wish Sequential support would pick up the damn phone. I've read rumours of a firmware issue that causes USB registry issues in OSX but who can confirm this??