Mopho Editor (LE) - File saving problem on mac

Mopho Editor (LE) - File saving problem on mac
« on: January 01, 2021, 06:34:10 AM »
I planned to spend yesterday afternoon/evening re-organising the factory presets on my Mopho into usable groups … but it was not to be. I now find that I cannot use the editor to save files. It seems to accept the save button but nothing appears in the file system (except maybe once just after loading the the editor, but then never again). Yeah, I know hard to believe.

This was working smoothly in September, and nothing that I can think of has changed since (still on High Sierra, need to update that).

Everything else works, editor talks to mopho, patches can be moved in both directions, but _not_saved to disk.

I spent hours on this, restored the app from september, restored the files from september, tried saving to different directories, loosened file permissions, tried manually creating files in those directories (which works) tried overwriting files from the app (doesn’t work). Removed extended attributes like quarantine.

Run out of ideas … I can’t even think of another way of moving these presets around … if you export sysexes, on reload they go back to the same preset number.

Actually it seems to be the restore of the App from backup then removing the quarantine attribute that allows saving files for a minute or so … then it goes back to not saving again.

I had some temporary success with this: go to the terminal, and run the command.

sudo spctl --add /Applications/Mopho\

Seems that without doing that, ‘gatekeeper’ thinks the app is untrustworthy. Unfortunately the effects of that don't last. App is now not saving again (an hour or so later). Maybe the gatekeeper blacklist of apps is updating in real time ?!?
« Last Edit: January 01, 2021, 06:49:38 AM by bibenu »


  • *****
  • 1812
Re: Mopho Editor (LE) - File saving problem on mac
« Reply #1 on: January 01, 2021, 06:55:01 AM »
Since it seems you're comfortable with the command line, you could try setting up a cronjob with the Gatekeeper command that runs every minute.

sudo crontab -uroot -e

and then add

* * * * * spctl --add /Applications/Mopho\

to the cron tab.
Prophet 5 Rev 4 #2711

MPC One+ ∙ MuseScore 4


Re: Mopho Editor (LE) - File saving problem on mac
« Reply #2 on: January 01, 2021, 08:05:40 AM »
Nice idea, thank you, but unfortunately the only time I've had success with spctl is on a new App. Either newly installed from zip (e.g. mopho_2) or newly restored from backup. Repeating the spctl command on the same app once it's broken has no effect.