The Official Sequential/DSI Forum

Prophet Rev2 Fault

Prophet Rev2 Fault
« on: November 19, 2020, 09:09:49 AM »

Hey all,

I've got a DSI Prophet Rev2 8-Voice synth, its been a real nice instrument for most of the time I've had it (just over a year). However, after relocating and setting back up my studio It seems to have developed a pretty serious fault - as far as I can tell - either that, or I'm going nuts.

I've included a clip below, that uses patches 1,2,3 (of bank 2 - all completely stock) to show the fault. Basically, as you should instantly hear, there's a horrid oscillation coming through. I don't remember that being there previously!

https://voca.ro/16LlXqLyoAkt

I know it's not my other studio gear, as I've run my JD800 through the same channels with no problems. It's definitely the synth, and the fault exists on both stereo outs.

I'm a degree qualified Electronic/Embedded Engineer, but I really don't fancy trying to fix this going in blind - Absolutely not my idea of a good time!

I'm hoping that someone will hear this, recognize the fault and be able to set me on a path to getting the thing fixed (whether that's replacing component 'X', or sending part 'X' to a shop). Gotta be worth a shot right?!

Thanks for any help,
Synth002.

Re: Prophet Rev2 Fault
« Reply #1 on: November 19, 2020, 09:32:07 AM »
Additional...

Just incase anyone suggests it - I've updated the firmware, cleared all global data, cleared calibration and re-calibrated.

Fault persists.

Synth002.

Re: Prophet Rev2 Fault
« Reply #2 on: November 20, 2020, 09:28:06 AM »
If you have not already, reach out to DSI support. They’ve been quick to respond to me in the past. Hopefully you can figure out what’s causing this and it can be repaired

MPM

Re: Prophet Rev2 Fault
« Reply #3 on: November 20, 2020, 06:14:09 PM »
there's a horrid oscillation coming through

Almost sounds like delay. try twiddling the FX parameters (both layer A and B).
Or a dicky LFO?
Have you tried the DSI cure-all, twist all the pots 100 times, press all the buttons 10 times, tear apart a chook and dance under a full moon?
« Last Edit: November 20, 2020, 06:17:27 PM by MPM »
OB-6  Prophet-6  Prophet.Rev2/16  no kids

Re: Prophet Rev2 Fault
« Reply #4 on: November 21, 2020, 03:01:01 AM »
Hey, thanks for the replies guys.

I've taken out a support ticket and am currently working to resolve the fault with one of the chaps at DSI. I also realized I had my purchase date confused - found the receipt and it's still under warranty, so hopefully this will be resolved before too long :).


there's a horrid oscillation coming through

Almost sounds like delay. try twiddling the FX parameters (both layer A and B).
Or a dicky LFO?
Have you tried the DSI cure-all, twist all the pots 100 times, press all the buttons 10 times, tear apart a chook and dance under a full moon?

lol, just checked the FX, makes no difference if they're on/off unfortunately.

Getting help from one of the DSI team now so I'm gonna have some faith!

Cheers,
Synth002.

Re: Prophet Rev2 Fault
« Reply #5 on: November 21, 2020, 11:13:41 AM »
Sounds like some sort of aliasing artifact, perhaps coming from the effects section? Defective ADC/DAC converters possibly?
Anyway, I'm sure the support team will sort this out for you. 
Minimoog D (vintage), OB6 (Desktop), Oberheim Matrix-6 (MIDI Controller), Prophet REV2-16, DeepMind 12, VC340