The Official Sequential/DSI Forum

Pro 3 & Ableton Live 10 settings for Ableton users step by step.

Hi,

Please someone be kind post here step by step Pro 3 & Ableton Live 10 settings step by step!


cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #1 on: May 14, 2020, 01:32:04 PM »
It's very easy.

Pro3 globals.

1. Set MIDI CLOCK MODE to SLAVE or SLAVE NO S/S (sequencer ignores start message).
2. Set MIDI CLOCK CABLE to USB or MIDI depending on which port you are using to transmit CLOCK data to the synth.
3. Set MIDI PARAM SEND and MIDI PARAM RECEIVE to CC.
4. Set LOCAL CONTROL OFF.
5. Set MIDI out to USB or MIDI depending on which port you are using to transmit MIDI data to Ableton.
6. Set MIDI PROGRAM SEND and MIDI PROGRAM RECEIVE ON
7. Set MIDI CONTROL ENABLE ON.

In Ableton.

1. Configure ableton to transmit clock to Pro3.
2. Add MIDI track for Pro 3 and set monitoring to in.

You're good to go!
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #2 on: May 14, 2020, 01:42:57 PM »
It's very easy.

Pro3 globals.

1. Set MIDI CLOCK MODE to SLAVE or SLAVE NO S/S (sequencer ignores start message).
2. Set MIDI CLOCK CABLE to USB or MIDI depending on which port you are using to transmit CLOCK data to the synth.
3. Set MIDI PARAM SEND and MIDI PARAM RECEIVE to CC.
4. Set LOCAL CONTROL OFF.
5. Set MIDI out to USB or MIDI depending on which port you are using to transmit MIDI data to Ableton.
6. Set MIDI PROGRAM SEND and MIDI PROGRAM RECEIVE ON
7. Set MIDI CONTROL ENABLE ON.

In Ableton.

1. Configure ableton to transmit clock to Pro3.
2. Add MIDI track for Pro 3 and set monitoring to in.

You're good to go!


Done all and still not working.

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #3 on: May 14, 2020, 01:45:56 PM »
I have the Pro 3 connected with a USB cable, and use the Soundtower Editor.  It works great with the latest beta firmware.
These are the settings that work for me with the editor.

I have one midi channel with an External Instrument device and the editor.

In Ableton Live's Preferences:
Midi Port In for the Pro 3 is all off!
Midi Port out for the Pro 3 is all on (track, sync, & remote).

Global Midi settings for the Pro 3 are as follows:
Midi Ch 1 (for my needs)
Midi Clock Mode: Slave (Slave no S/S if you don't want the sequencer to play when you start Live)
Midi Clock Cable In: USB
Midi Clock Cable Out: USB
Midi Param Send: NRPN (needed for the editor)
Midi Param Receive: NRPN (needed for the editor)
Midi Control: On
Midi Sysex: On
Midi Sysex Cable: USB
Midi Out: All
Midi Program Send: Off (this helps with track select adjustments from not messing up the patch your on the Pro 3 with the editor. patch recall and send is done with sysex).
Midi Program Receive: On
Midi Arp / Seq Note: On
Midi Arp Beat Quantize: On

In the Pro 3's Global General settings:
I have Local set to On.  This works fine now when all those other settings are set correctly.

Hope that helps.  anything else probably means you have an other midi controller or sequencer creating a midi loop.

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #4 on: May 14, 2020, 01:49:33 PM »
It's very easy.

Pro3 globals.

1. Set MIDI CLOCK MODE to SLAVE or SLAVE NO S/S (sequencer ignores start message).
2. Set MIDI CLOCK CABLE to USB or MIDI depending on which port you are using to transmit CLOCK data to the synth.
3. Set MIDI PARAM SEND and MIDI PARAM RECEIVE to CC.
4. Set LOCAL CONTROL OFF.
5. Set MIDI out to USB or MIDI depending on which port you are using to transmit MIDI data to Ableton.
6. Set MIDI PROGRAM SEND and MIDI PROGRAM RECEIVE ON
7. Set MIDI CONTROL ENABLE ON.

In Ableton.

1. Configure ableton to transmit clock to Pro3.
2. Add MIDI track for Pro 3 and set monitoring to in.

You're good to go!


Done all and still not working.

That should work.  You might want to reset the global parameters on your synth and reconfigure it as outlined above.

To reset the globals, press the GLOBAL button, navigate to the RESET GLOBALS menu item, and press the WRITE button.
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #5 on: May 14, 2020, 02:02:13 PM »
I have the Pro 3 connected with a USB cable, and use the Soundtower Editor.  It works great with the latest beta firmware.
These are the settings that work for me with the editor.

I have one midi channel with an External Instrument device and the editor.

In Ableton Live's Preferences:
Midi Port In for the Pro 3 is all off!
Midi Port out for the Pro 3 is all on (track, sync, & remote).

Global Midi settings for the Pro 3 are as follows:
Midi Ch 1 (for my needs)
Midi Clock Mode: Slave (Slave no S/S if you don't want the sequencer to play when you start Live)
Midi Clock Cable In: USB
Midi Clock Cable Out: USB
Midi Param Send: NRPN (needed for the editor)
Midi Param Receive: NRPN (needed for the editor)
Midi Control: On
Midi Sysex: On
Midi Sysex Cable: USB
Midi Out: All
Midi Program Send: Off (this helps with track select adjustments from not messing up the patch your on the Pro 3 with the editor. patch recall and send is done with sysex).
Midi Program Receive: On
Midi Arp / Seq Note: On
Midi Arp Beat Quantize: On

In the Pro 3's Global General settings:
I have Local set to On.  This works fine now when all those other settings are set correctly.

Hope that helps.  anything else probably means you have an other midi controller or sequencer creating a midi loop.


I do have another NI Komplete Kontrol but now it's switched off and still the same problem. Maybe the Komplete Kontrol controller is making a conflict dunno...

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #6 on: May 14, 2020, 02:09:25 PM »
Please reset the globals and configure the synth as outlined in my previous email.  It should work correctly thereafter assuming there isn't something else in your setup which is causing problems.
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #7 on: May 14, 2020, 02:15:12 PM »
Please reset the globals and configure the synth as outlined in my previous email.  It should work correctly thereafter assuming there isn't something else in your setup which is causing problems.


I have done the reset now and still not working. I have another NI Komplete Kontrol usb controller connected with my ableton here maybe this is the problem?

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #8 on: May 14, 2020, 02:16:35 PM »
Yes, you could try removing all other gear from the setup to aid in troubleshooting.

What exactly do you mean by "it's still not working"?  Specifically what is not working?
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #9 on: May 14, 2020, 02:21:46 PM »
Yes, you could try removing all other gear from the setup to aid in troubleshooting.

What exactly do you mean by "it's still not working"?  Specifically what is not working?


Removed the Komplete Kontrol and still no sound from the Pro3 with local control OFF.

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #10 on: May 14, 2020, 02:28:46 PM »
Do you have the MIDI track in ableton set with MONITOR set to IN?
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #11 on: May 14, 2020, 02:33:16 PM »
I have the Pro 3 connected with a USB cable, and use the Soundtower Editor.  It works great with the latest beta firmware.
These are the settings that work for me with the editor.

I have one midi channel with an External Instrument device and the editor.

In Ableton Live's Preferences:
Midi Port In for the Pro 3 is all off!
Midi Port out for the Pro 3 is all on (track, sync, & remote).

Global Midi settings for the Pro 3 are as follows:
Midi Ch 1 (for my needs)
Midi Clock Mode: Slave (Slave no S/S if you don't want the sequencer to play when you start Live)
Midi Clock Cable In: USB
Midi Clock Cable Out: USB
Midi Param Send: NRPN (needed for the editor)
Midi Param Receive: NRPN (needed for the editor)
Midi Control: On
Midi Sysex: On
Midi Sysex Cable: USB
Midi Out: All
Midi Program Send: Off (this helps with track select adjustments from not messing up the patch your on the Pro 3 with the editor. patch recall and send is done with sysex).
Midi Program Receive: On
Midi Arp / Seq Note: On
Midi Arp Beat Quantize: On

In the Pro 3's Global General settings:
I have Local set to On.  This works fine now when all those other settings are set correctly.

Hope that helps.  anything else probably means you have an other midi controller or sequencer creating a midi loop.

So are you saying you can use the editor with Ableton open? I seem to be able to only open one or the other, even with Midi port In for Pro 3 OFF. It just wont connect if I open ableton first

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #12 on: May 14, 2020, 03:03:17 PM »
If you set the track to auto, you will only hear the Pro 3 when you are recording.  You can just set monitor to off when using the Pro3 as a controller for other gear.
Sequential

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #13 on: May 14, 2020, 03:04:00 PM »
So are you saying you can use the editor with Ableton open? I seem to be able to only open one or the other, even with Midi port In for Pro 3 OFF. It just wont connect if I open ableton first

I'm using the Plugin version in the DAW.
I don't think the standalone version will work with a DAW running at the same time.

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #14 on: May 14, 2020, 04:45:46 PM »
I'm using the Plugin version in the DAW.
I don't think the standalone version will work with a DAW running at the same time.

Yeah, normally you can't run the standalone versions of editors along with a DAW being connected to instrument, because of programs taking exclusive control over MIDI ports.    There is a workaround with certain MIDI interfaces or software however.    This video explains how to do it with MIO MIDI Interfaces:

https://www.youtube.com/watch?v=SqapYg5bgmU


Voice Component Modeling (VCM) Soundset - 128 Patches for the Prophet Rev2 - NOW AVAILABLE on Sellfy: https://sellfy.com/p/figZ/

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #15 on: May 15, 2020, 02:19:54 AM »
Thanks I didn't realise there was a VST version already. My setup only allows one connection but there seems to be a workaround with the VST setup

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #16 on: May 17, 2020, 11:10:36 AM »

Hi
I installed the PRO 3 VST/AU PlugSE
I have set all the settings
I work with cubase 10.5
 Everything works except the  "Read"  on the automation

It can record (Write) the note and the automation From the PRO 3 VST/AU PlugSE
And also from pro 3 hardware

I can see the automation  recording in cubase

But it does not send the recording ( "Read" ) of  automation 
 the knob Not moving on the  PRO 3 PlugSE From the automation recording I did


what am I missing.... :-[






I have the Pro 3 connected with a USB cable, and use the Soundtower Editor.  It works great with the latest beta firmware.
These are the settings that work for me with the editor.

I have one midi channel with an External Instrument device and the editor.

In Ableton Live's Preferences:
Midi Port In for the Pro 3 is all off!
Midi Port out for the Pro 3 is all on (track, sync, & remote).

Global Midi settings for the Pro 3 are as follows:
Midi Ch 1 (for my needs)
Midi Clock Mode: Slave (Slave no S/S if you don't want the sequencer to play when you start Live)
Midi Clock Cable In: USB
Midi Clock Cable Out: USB
Midi Param Send: NRPN (needed for the editor)
Midi Param Receive: NRPN (needed for the editor)
Midi Control: On
Midi Sysex: On
Midi Sysex Cable: USB
Midi Out: All
Midi Program Send: Off (this helps with track select adjustments from not messing up the patch your on the Pro 3 with the editor. patch recall and send is done with sysex).
Midi Program Receive: On
Midi Arp / Seq Note: On
Midi Arp Beat Quantize: On

In the Pro 3's Global General settings:
I have Local set to On.  This works fine now when all those other settings are set correctly.

Hope that helps.  anything else probably means you have an other midi controller or sequencer creating a midi loop.

Re: Pro 3 & Ableton Live 10 settings for Ableton users step by step.
« Reply #17 on: May 20, 2020, 03:06:17 AM »
I found the problem .... finally  :)

You only have to choose the sound only from the PRO 3 VST/AU PlugSE
Then everything works!!!

If you choose the sound from the PRO 3 hardware
the problem comes back
strange...

Currently the solution
I look for sound in the hardware ... and then load it again on  PRO 3 VST
For everything to work...







Hi
I installed the PRO 3 VST/AU PlugSE
I have set all the settings
I work with cubase 10.5
 Everything works except the  "Read"  on the automation

It can record (Write) the note and the automation From the PRO 3 VST/AU PlugSE
And also from pro 3 hardware

I can see the automation  recording in cubase

But it does not send the recording ( "Read" ) of  automation 
 the knob Not moving on the  PRO 3 PlugSE From the automation recording I did


what am I missing.... :-[






I have the Pro 3 connected with a USB cable, and use the Soundtower Editor.  It works great with the latest beta firmware.
These are the settings that work for me with the editor.

I have one midi channel with an External Instrument device and the editor.

In Ableton Live's Preferences:
Midi Port In for the Pro 3 is all off!
Midi Port out for the Pro 3 is all on (track, sync, & remote).

Global Midi settings for the Pro 3 are as follows:
Midi Ch 1 (for my needs)
Midi Clock Mode: Slave (Slave no S/S if you don't want the sequencer to play when you start Live)
Midi Clock Cable In: USB
Midi Clock Cable Out: USB
Midi Param Send: NRPN (needed for the editor)
Midi Param Receive: NRPN (needed for the editor)
Midi Control: On
Midi Sysex: On
Midi Sysex Cable: USB
Midi Out: All
Midi Program Send: Off (this helps with track select adjustments from not messing up the patch your on the Pro 3 with the editor. patch recall and send is done with sysex).
Midi Program Receive: On
Midi Arp / Seq Note: On
Midi Arp Beat Quantize: On

In the Pro 3's Global General settings:
I have Local set to On.  This works fine now when all those other settings are set correctly.

Hope that helps.  anything else probably means you have an other midi controller or sequencer creating a midi loop.