The Official Sequential/DSI Forum

Pro 3 Major Issues--Dud? Help needed.

Pro 3 Major Issues--Dud? Help needed.
« on: March 28, 2020, 02:22:41 PM »
Hi, I just got a Pro-3 and it's very strange.  I've had a lot of synths and think something is wrong but would appreciate any input. Maybe there is a setting or something I'm missing. Here's the issue:

When I change parameters with the knobs, many go well past 127 or 100.  For instance the cutoff goes from 0 to 1021.  1-127 is a normal sweep, and then 128 is like 1 again, and so on up to 1021.  Is this normal? The fine tune goes from -700 to +700, recycling at 127.  I've never seen a synth like this and, if it's intended, this is not the synth for me.   The OSC 1 level goes from 4 -127.  I'm not sure why it starts on 4.  The shape mod goes to 255, resetting at 128. The envelope controls all seem to work, going from 0-127, some of the effects knobs work normally, others don't.  I'm loathe to have to return this, ship it,  and wait weeks for another but I can't imagine this is intended.  Any clues?

One note: I was running this through MIDI using Ableton to control it.  When I don't do that, the stepping on the knobs goes away.  So the cutoff still goes from 0-1021, but doesn't reset at 127.  If I run it through midi, then it resets at 127, and again after each 127.

As an update, another problem is now occurring. When I turn the "program" knob, the program number changes, but not the name or the actual program.  This makes no sense.  The unit is brand new.



Thanks,

« Last Edit: March 28, 2020, 03:07:19 PM by qwatkins »

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #1 on: March 28, 2020, 02:59:13 PM »
Some parameters have finer resolution than others, allowing you to fine-tune patches but also get smoother transitions when using knobs. The filter should go up to 1023, +/-700 is normal for the fine tuning, etc. The range on the fine tuning, for example, allows for subtle detuning that might not be possible if the range were just 1-127. It does mean that values aren't consistent, i.e. 127 isn't always maximum, but it provides much greater resolution on parameters where it is most important.

As for osc level starting at 4, you probably want to reach out to support.

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #2 on: March 28, 2020, 03:08:36 PM »
Some parameters have finer resolution than others, allowing you to fine-tune patches but also get smoother transitions when using knobs. The filter should go up to 1023, +/-700 is normal for the fine tuning, etc. The range on the fine tuning, for example, allows for subtle detuning that might not be possible if the range were just 1-127. It does mean that values aren't consistent, i.e. 127 isn't always maximum, but it provides much greater resolution on parameters where it is most important.

As for osc level starting at 4, you probably want to reach out to support.

Thank you very much, I figured that might be the case but was confused by the resetting after each 127.  Any ideas on that? I've noticed that the resetting goes away when I don't run it through MIDI, so maybe its a MIDI implementation thing?  I'm trying to work through it still and probably shouldn't post here and bother you all until I've exhausted that process, but I appreciate the insight which is helpful as I go.  I think I'm in a MIDI loop that I need to turn off somehow.
« Last Edit: March 28, 2020, 03:18:45 PM by qwatkins »

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #3 on: March 28, 2020, 03:14:01 PM »
Some parameters have finer resolution than others, allowing you to fine-tune patches but also get smoother transitions when using knobs. The filter should go up to 1023, +/-700 is normal for the fine tuning, etc. The range on the fine tuning, for example, allows for subtle detuning that might not be possible if the range were just 1-127. It does mean that values aren't consistent, i.e. 127 isn't always maximum, but it provides much greater resolution on parameters where it is most important.

As for osc level starting at 4, you probably want to reach out to support.

Thank you I figured that might be the case.  What about the resetting at each 127? I've noticed that the resetting goes away when I don't run it through MIDI, so maybe its a MIDI implementation thing.
I'm not sure what you mean by resetting. You're saying that the filter cutoff for example is continuous from 0-1023 without MIDI cables attached but behaves differently if you have incoming MIDI?

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #4 on: March 28, 2020, 03:22:31 PM »
Some parameters have finer resolution than others, allowing you to fine-tune patches but also get smoother transitions when using knobs. The filter should go up to 1023, +/-700 is normal for the fine tuning, etc. The range on the fine tuning, for example, allows for subtle detuning that might not be possible if the range were just 1-127. It does mean that values aren't consistent, i.e. 127 isn't always maximum, but it provides much greater resolution on parameters where it is most important.

As for osc level starting at 4, you probably want to reach out to support.

Thank you I figured that might be the case.  What about the resetting at each 127? I've noticed that the resetting goes away when I don't run it through MIDI, so maybe its a MIDI implementation thing.
I'm not sure what you mean by resetting. You're saying that the filter cutoff for example is continuous from 0-1023 without MIDI cables attached but behaves differently if you have incoming MIDI?

Yes.  So if I'm running through MIDI in Abelton (turning local control off) the cutoff is closed at 1, fully open at 127, and then fully closed at 128, then open again after another 127....This seems to be effected by whether or not I have it set to receive MIDI parameters.  If I turn MIDI Para Receive to off, the resetting doesn't happen.  My guess is there is a way to set up Ableton to account for this but I haven't figured it out yet. 

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #5 on: March 28, 2020, 05:46:33 PM »
My guess is that you have some kind of MIDI feedback loop happening in Live or your routing.  Make sure you're not sending or receiving signals to the Pro 3 you don't actually need in Live's MIDI Preferences view.  Turn off MIDI input from the Pro 3 to any tracks that don't need it as well.

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #6 on: March 28, 2020, 06:52:01 PM »
Wasnít there someone who mentioned that USB midi is a bit squiffy at present and a known issue?

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #7 on: March 28, 2020, 09:22:21 PM »
Wasnít there someone who mentioned that USB midi is a bit squiffy at present and a known issue?

I do use USB, but I couldn't find anyone having this problem.  When I turn off MIDI parameter receive in the Pro 3, the problem is fixed.  Then, of course, the problem is that I can't receive MIDI automation. 

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #8 on: March 29, 2020, 03:29:11 PM »
Wasnít there someone who mentioned that USB midi is a bit squiffy at present and a known issue?

Yes I mentioned that. If you send Midi CC via USB the most knobs send also the CC 7. Sequential knows about this and will fix it in the next firmware update. Via normal midi all works fine.

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #9 on: March 30, 2020, 12:31:28 PM »
Just to confirm, I received a Pro3 in the past few days and have exactly the same issue. It's basically unusable with a DAW over USB. I also have to switch the Pro3 off and on to get it working as a controller in Ableton. I almost returned the unit to the retailer.

Support told me they are working on a fix but would not commit to a timeline.

cbmd

  • *****
  • 291
    • Sequential
Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #10 on: March 30, 2020, 06:55:18 PM »
Many of these sound like MIDI feedback loops and/or using Ableton without changing the synth to send/receive CC messages instead of NRPN messages.  A good place to start to test would be to remove all MIDI/USB connectivity from the synth and check whether the issues are still present.  If the issues are no longer present, then the problem is related to MIDI transmission specifically.

There is a known bug where hot swapping the USB will cause MIDI transmission to cease to operate.  Just power cycle the synth with the USB connected to fix this. 

If you are using ABLETON, make sure to set the MIDI PARAM SEND and RECEIVE global parameters to CC.  Ableton does not support the use of NRPNs.  If the Pro 3 is set to send/receive NRPNs many unexpected behaviors will occur when connected to/from Ableton.
Sequential

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #11 on: March 30, 2020, 08:10:45 PM »
Many of these sound like MIDI feedback loops and/or using Ableton without changing the synth to send/receive CC messages instead of NRPN messages.  A good place to start to test would be to remove all MIDI/USB connectivity from the synth and check whether the issues are still present.  If the issues are no longer present, then the problem is related to MIDI transmission specifically.

There is a known bug where hot swapping the USB will cause MIDI transmission to cease to operate.  Just power cycle the synth with the USB connected to fix this. 

If you are using ABLETON, make sure to set the MIDI PARAM SEND and RECEIVE global parameters to CC.  Ableton does not support the use of NRPNs.  If the Pro 3 is set to send/receive NRPNs many unexpected behaviors will occur when connected to/from Ableton.

I was having the issue as well and switched from NRPN to CC. Seems to be functioning fine but have only tested for 20min or so. I have another issue where arps are not functioning. Still need to search around before I post. Even tho I kinda just did. >__<

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #12 on: April 01, 2020, 02:22:22 PM »
Switching to CC makes no difference for me. Same issue prevails.

Re: Pro 3 Major Issues--Dud? Help needed.
« Reply #13 on: April 05, 2020, 02:33:11 PM »
I can confirm OS 1.0.1.1. appears to have fixed the USB MIDI parameter issue for me. Support didn't make me aware of the OS update, I fortunately spotted the pinned forum post.