The Official Sequential/DSI Forum

Bug thread

Bug thread
« on: March 27, 2020, 07:01:43 AM »
I think it would be more useful if we listed bugs in one thread ?

This is what Iíve found when using it local off anyway.


Arpeggiator unable to switch off and on, freezing up.

Effects turning on and off via buttons, but not actually switching effect sound off. I.e turn reverb off , light goes out but reverb sound still heard.

Sequencer not getting triggered at right octave , think this is midi in Ableton. Maybe missing first note on. Need to play with latency.

Please discuss or add your own, just think it will cut down on unanswered threads if we can reference them all in one place.

Cheers, Chris
« Last Edit: March 27, 2020, 07:03:20 AM by h4ndcrafted »

Re: Bug thread
« Reply #1 on: March 28, 2020, 02:46:03 AM »
Also got this issue

Wave shape seems to leak noise sometimes , a restart fixes it for a while.

With the wave oN triangle and wave mod to far right I get what sounds like a sine at first then it leaks a crunchy sort of white noise.
On restart itís just like a sine.


https://youtu.be/7D40geU1OnE
« Last Edit: March 28, 2020, 02:49:20 AM by h4ndcrafted »

Re: Bug thread
« Reply #2 on: March 29, 2020, 12:31:25 AM »
I have tons of bugs.  When I think I fix one, another comes up.  Maybe its me, but so far I'm not able to fix these main things (other stuff pops up here and there too):

(1) Using USB for MIDI, if parameter receive is on, numerous knobs don't function properly.  For instance, the cutoff will reset at 127, even though it goes to 1021.  So 128 is the same as 1, etc.  If I stop using USB MIDI, this has no effect.

(2) The latch button lights up but has no effect on the arp.  It doesn't latch.

(3) Sometimes the pitch knob stops working. It won't change the pitch or number.  I can change the pitch using the knobs by the screen.  A global reset fixes this.

(4) USB MIDI out worked for a few hours, and then just completely stopped working.

Should I return the unit, can this be fixed, or is this just the state of the machine?


jg666

  • ***
  • 339
Re: Bug thread
« Reply #3 on: March 29, 2020, 03:05:02 AM »
Re the Latch button, on the Pro2 (I donít have a Pro3) the Latch button is for the slider and itís the Hold button that you press to latch an Arp etc.

Apologies if it is the Hold button youíre pressing :)
DSI Prophet Rev2, DSI Pro 2, Moog Sub37, Korg Minilogue, Yamaha MOXF6, Yamaha MODX6

Re: Bug thread
« Reply #4 on: March 29, 2020, 03:25:27 PM »
(1) Using USB for MIDI, if parameter receive is on, numerous knobs don't function properly.  For instance, the cutoff will reset at 127, even though it goes to 1021.  So 128 is the same as 1, etc.  If I stop using USB MIDI, this has no effect.

Point 1 is a bug and Sequential knows it and will fix it with the next firmware update.

Re: Bug thread
« Reply #5 on: March 29, 2020, 05:28:24 PM »
For what itís worth, almost all bugs I have is transmitting through Live. If I use it with local on it works great.

But yeah a ton of bugs when using it local off.

Re: Bug thread
« Reply #6 on: March 30, 2020, 05:55:56 AM »
Always best to submit any bug reports to the dedicated support email address/online form as itís the only way to guarantee theyíll be seen. They are always pretty responsive in answering too.

Re: Bug thread
« Reply #7 on: March 30, 2020, 07:30:44 AM »
I've only had a few bugs:

Sometimes I can't sequence a knob parameter and control its full range.  The sequencer will only record a couple value changes for a tiny portion of the knobs motion.  I see this with the osc shape parameter a lot. 

Writing a preset stops the sequencer.

The display freaks out sometimes if I'm turning multiple knobs from different synth sections. Like it can't make up its mind which parameter to show and gets stuck for awhile showing pixelated bits of both.  This will stick on the display for a few seconds even after I stop tweaking.

Re: Bug thread
« Reply #8 on: March 30, 2020, 10:26:46 AM »
Always best to submit any bug reports to the dedicated support email address/online form as itís the only way to guarantee theyíll be seen. They are always pretty responsive in answering too.
Yup. A list might be handy for some users but Sequential doesnít read every single post here.

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #9 on: March 30, 2020, 07:02:53 PM »
I've only had a few bugs:

Sometimes I can't sequence a knob parameter and control its full range.  The sequencer will only record a couple value changes for a tiny portion of the knobs motion.  I see this with the osc shape parameter a lot. 

Writing a preset stops the sequencer.

The display freaks out sometimes if I'm turning multiple knobs from different synth sections. Like it can't make up its mind which parameter to show and gets stuck for awhile showing pixelated bits of both.  This will stick on the display for a few seconds even after I stop tweaking.

Any parameter data recorded to the sequencer is entered relative to the physical pot position.  For example, with the LP cutoff set to minimum, any data will be recorded with a value of 0-511.  With the cutoff pot at it's mid point (512), recorded data will be entered from -255 to +255 and so on.  Sounds like this is what you were noting.

It is expected for the sequencer to stop when writing a preset.

When you have encountered the issue with the display 'freaking' out, do you have any MIDI/USB running to/from the synth?   Check whether disconnecting MIDI/USB causes this to cease.  My first guess is that there is a large number of controller messages being queued on the bus.
Sequential

Re: Bug thread
« Reply #10 on: March 31, 2020, 07:15:39 AM »
My issue is that even with a pot at midpoint, I can't get the full -255 to +255 range, sometimes it will only go to say -48 even though I can still physically turn the knob further than that still. My knob mode is set to Jump FWIW.

For the display bug, I do not have any midi or usb hooked up, and I have the pro3 set to not receive or transmit those as well.

S Y Z Y G Y X

  • **
  • 118
  • WWW.SYZYGYXMUSIC.COM
    • S Y Z Y G Y X
Re: Bug thread
« Reply #11 on: March 31, 2020, 08:02:38 AM »
My Pro 3 will record midi notes into Logic, but half the time it will not play the notes back.  The arpeggiator on and functioning normally the midi notes will not play back from Logic.  I turn off the Pro 3, turn it back on and then I press the Arp button, the arp button will sometimes malfunction and stop the arp when I play another key.  It is when that malfunction is happening with the Arpeggiator that midi notes will play back from Logic!!

This is driving me mad and makes this synth not useable for me if this canít be fixed. 

I plugged in my Evolver Keyboard to the exact same midi ports on my MOTU and the Evolver works perfectly normal.  Sequential if you see this I need help Bad!  Im at work until 3 pm your time so will be calling you guys then!

Please helllllp.  This was my dream synth
SEQUENTIAL Pro 3, DSI Prophet Rev2-8, DSI Mono Evolver Keyboard, Moog Subsequent 37, Roland Alpha Juno 2, Novation Bass Station 2, BOSS VE500, MOTU Micro Lite, AKAI APC240 MKII, UAD Apollo X6, MacBook Pro 2017, ADAM A7X Monitors, Logic X
www.syzygyxmusic.com
https://syzygy-x.bandcamp.com

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #12 on: March 31, 2020, 08:43:59 AM »
My issue is that even with a pot at midpoint, I can't get the full -255 to +255 range, sometimes it will only go to say -48 even though I can still physically turn the knob further than that still. My knob mode is set to Jump FWIW.

For the display bug, I do not have any midi or usb hooked up, and I have the pro3 set to not receive or transmit those as well.

Yes, that is the correct behavior when recording.  Using the OSC SHAPE param as an example, the range of the parameter itself is 255.  If you have it set to its mid point prior to recording, you will only be able to record +/- 127.  With the pot set to minimum, its recorded range will be from 0-127 etc.

When two different parameters on two different screens are used, it is expected for the display to jump between both parameters as they're values are updated.  The screen should, however, stop updating a parameters value when the parameters is no longer being changed.
Sequential

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #13 on: March 31, 2020, 08:50:04 AM »
My Pro 3 will record midi notes into Logic, but half the time it will not play the notes back.  The arpeggiator on and functioning normally the midi notes will not play back from Logic.  I turn off the Pro 3, turn it back on and then I press the Arp button, the arp button will sometimes malfunction and stop the arp when I play another key.  It is when that malfunction is happening with the Arpeggiator that midi notes will play back from Logic!!

This is driving me mad and makes this synth not useable for me if this canít be fixed. 

I plugged in my Evolver Keyboard to the exact same midi ports on my MOTU and the Evolver works perfectly normal.  Sequential if you see this I need help Bad!  Im at work until 3 pm your time so will be calling you guys then!

Please helllllp.  This was my dream synth

Do you have the global MIDI ARP NOTE parameter set on or off?
Sequential

S Y Z Y G Y X

  • **
  • 118
  • WWW.SYZYGYXMUSIC.COM
    • S Y Z Y G Y X
Re: Bug thread
« Reply #14 on: March 31, 2020, 09:07:10 AM »
I will check that when I get home , but also this behavior....when the arpeggiator is on and itís malfunctioning by not triggering an arp on the next key I play, if I unplug just the midi out cable from the back of the Pro 3, then the Arpeggiator will begin to function normally.

I have 3 videos I recorded on my phone documenting all of these issues... Is there an email that I can send these videos to so that you can see exactly what is happening?

Thank you, I really hope this can be fixed...
SEQUENTIAL Pro 3, DSI Prophet Rev2-8, DSI Mono Evolver Keyboard, Moog Subsequent 37, Roland Alpha Juno 2, Novation Bass Station 2, BOSS VE500, MOTU Micro Lite, AKAI APC240 MKII, UAD Apollo X6, MacBook Pro 2017, ADAM A7X Monitors, Logic X
www.syzygyxmusic.com
https://syzygy-x.bandcamp.com

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #15 on: March 31, 2020, 09:29:54 AM »
I will check that when I get home , but also this behavior....when the arpeggiator is on and itís malfunctioning by not triggering an arp on the next key I play, if I unplug just the midi out cable from the back of the Pro 3, then the Arpeggiator will begin to function normally.

I have 3 videos I recorded on my phone documenting all of these issues... Is there an email that I can send these videos to so that you can see exactly what is happening?

Thank you, I really hope this can be fixed...

Any problems should always be reported directly to our support department at support@sequential.com

The other parameter to check would be whether local control is on or off.  a MIDI feedback loop could also cause the behavior you noted.
Sequential

Re: Bug thread
« Reply #16 on: March 31, 2020, 09:36:45 AM »
Yes, that is the correct behavior when recording.  Using the OSC SHAPE param as an example, the range of the parameter itself is 255.  If you have it set to its mid point prior to recording, you will only be able to record +/- 127.  With the pot set to minimum, its recorded range will be from 0-127 etc.

I think you're misunderstanding me.  You're right when OSC shape is set to mid point, I should be able to record +/-127.  My issue is that this is NOT happening, I am only sometimes only able to record (for instance) -40 to +127.  Or maybe it's -100 to +35, the actual numbers vary every time this happens.  I am unable to get the full range recorded that I should be able to, the Pro3 is only recognizing a small portion of the range I should be able to access.  Happens randomly, usually it works as it should, so I'm having issue tracking down the root cause of this.

S Y Z Y G Y X

  • **
  • 118
  • WWW.SYZYGYXMUSIC.COM
    • S Y Z Y G Y X
Re: Bug thread
« Reply #17 on: March 31, 2020, 09:51:16 AM »
Local control is set to ON, but i need it set to on because if not, I cannot play the Pro 3 fr the keyboard which is how I compose music into Logic.

Is there a way to have local control set to off but still be able to play the synth as an external instrument in logic?  By being able to play the keys and record knob midi information into logic?

SEQUENTIAL Pro 3, DSI Prophet Rev2-8, DSI Mono Evolver Keyboard, Moog Subsequent 37, Roland Alpha Juno 2, Novation Bass Station 2, BOSS VE500, MOTU Micro Lite, AKAI APC240 MKII, UAD Apollo X6, MacBook Pro 2017, ADAM A7X Monitors, Logic X
www.syzygyxmusic.com
https://syzygy-x.bandcamp.com

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #18 on: March 31, 2020, 09:53:30 AM »
Yes, that is the correct behavior when recording.  Using the OSC SHAPE param as an example, the range of the parameter itself is 255.  If you have it set to its mid point prior to recording, you will only be able to record +/- 127.  With the pot set to minimum, its recorded range will be from 0-127 etc.

I think you're misunderstanding me.  You're right when OSC shape is set to mid point, I should be able to record +/-127.  My issue is that this is NOT happening, I am only sometimes only able to record (for instance) -40 to +127.  Or maybe it's -100 to +35, the actual numbers vary every time this happens.  I am unable to get the full range recorded that I should be able to, the Pro3 is only recognizing a small portion of the range I should be able to access.  Happens randomly, usually it works as it should, so I'm having issue tracking down the root cause of this.

Ok.  I haven't ever seen anything like that occurring.  If you can get reproducible steps to show the problem we can check it out.
Sequential

cbmd

  • *****
  • 291
    • Sequential
Re: Bug thread
« Reply #19 on: March 31, 2020, 09:56:32 AM »
Local control is set to ON, but i need it set to on because if not, I cannot play the Pro 3 fr the keyboard which is how I compose music into Logic.

Is there a way to have local control set to off but still be able to play the synth as an external instrument in logic?  By being able to play the keys and record knob midi information into logic?

Yes, you can set LOCAL CONTROL off and have logic pass the Pro3's output MIDI data back to the Pro 3.
Sequential