The Official Sequential/DSI Forum

Weird dimly lit indicators on panel

Weird dimly lit indicators on panel
« on: March 05, 2020, 10:38:56 AM »
Hi,
I put in a support ticket, but just in case someone has experienced this, I thought I might also post here.

Issues:

1)  The Click, Sounds, and 16 Beats are blinking at a dim level, even when not depressed.

2) The Click won't turn on/off

3) The Tempest make a very loud crackling noise when powered on

Maybe #3 is "normal" but I've never experienced this with any synth or piece of gear.

The thing that is really odd is that in not one of the tutorial videos by Sequential or others, have I seen dimly lit indicator lights. 

Any thoughts?

Re: Weird dimly lit indicators on panel
« Reply #1 on: March 05, 2020, 01:35:16 PM »
For #3, it seems to be a thing with some Sequential gear. My current Tempest and the one I had before it both "pop" loudly when I turn it on. And if I recall correctly, either my old Mopho x4 or Rev2 did also.

Re: Weird dimly lit indicators on panel
« Reply #2 on: March 06, 2020, 12:24:12 AM »
#3 is expected behavior and has being criticized heavily but all users..
The other issues are a not normal behavior and indicates a hardware issue.Itís good that you contacted support the guys are excellent!

Re: Weird dimly lit indicators on panel
« Reply #3 on: March 06, 2020, 07:15:08 AM »
#3 is expected behavior and has being criticized heavily but all users..
The other issues are a not normal behavior and indicates a hardware issue.Itís good that you contacted support the guys are excellent!

Unfortunately, it does seem to be a hardware issue, but you are absolutely correct about the support. It was bad luck that I got a device with issues, but because of the service, instead of just sending it back and being done with it, I decided to have it replaced.

My only problem now is that after putting in a Damaged/Replacement notice in with Thomann.de here in Germany, they are dragging their feet to get me the packing slip to send it back. So, in other words, if I were an ass and just sent it back, then ordered another right away, dumping it on the next poor soul who received it, I'm doing the right thing and reporting it defective (with the links to Sequential service). If they make me get it serviced instead of taking it back, I'll never order with them again and take my thousands of Euros gear-spend elsewhere.

The whole thing is frustrating, but I'm at least fairly confident I'll get it sorted.

Re: Weird dimly lit indicators on panel
« Reply #4 on: March 11, 2020, 04:35:13 PM »
In regards to #1, I noticed recently when taking apart the Tempest that some LEDs have like little unheated shrink tubes around them, small little black tubes, which I think are meant to prevent light bleed. However, some of them fell off when I was disassembling the Tempest, and I'm unsure which LEDs they should be on. Maybe some of those tubes are missing from your Tempest?

Can anyone at DSI chime in and advise which LEDs should have those tubes around them? I might just cut some down myself and place them around all of the LEDs.