The Official Sequential/DSI Forum

Pro 2 USB issues (Sound Glitches)

Pro 2 USB issues (Sound Glitches)
« on: March 16, 2016, 01:33:41 AM »
Hey guys,

I have some issues with my Pro 2 regarding it's USB connection. Since some days I had strange crackling & rumbling digital noises, not too loud, though noticeable coming from my monitors. They were also noticeable on bounces of tracks I've made. I went through several solutions and tried various things, thinking the sound was made up by circuit errors or my iMac I run everything through.

At last I discovered that when my Pro 2 was not connected via an input to the interface, the noises disappeared. I then checked different cables and other inputs, but as soon as it was connected the noises came again, even though the Pro 2 was also turned off and not even connected to a circuit! I then pulled off the USB cable it received it's MIDI through and the noises disappeared. I double checked, using other USB cables and also setting all the MIDI settings to USB in the menu, but as soon as I have my Pro 2 connected via USB, I am having these sound issues and the glitching noises.

Of course I think about sending it in for a repair as I guess that the USB hub is broken. But beforehand - did any other of you guys had this issue already or heard of it ? Maybe there is a solution keeping me away from sending the synth away and having to work without it for several days or weeks. Hope someone can help with this.

Btw, I am running it with MIDI cables now, works perfectly fine!

Re: Pro 2 USB issues (Sound Glitches)
« Reply #1 on: March 16, 2016, 02:01:57 AM »
Just to check:

If you connect the audio outs of the P2 to your interface and also connect the USB cable to your computer, even when the P2 is turned off you are getting noise out of the P2 audio outs?

Is this noise on the headphone outs as well?

What audio interface is it?

Re: Pro 2 USB issues (Sound Glitches)
« Reply #2 on: March 16, 2016, 04:38:26 AM »
Yes that's right! The noises also can be heard via the headphone out.

Interface I use is the RME Fireface 400, newest software update is installed.

Re: Pro 2 USB issues (Sound Glitches)
« Reply #3 on: March 16, 2016, 04:46:41 AM »
For a test, remove the cables from the audio outs on the P2.

Does the noise disappear from the headphones?

Re: Pro 2 USB issues (Sound Glitches)
« Reply #4 on: March 16, 2016, 06:50:18 AM »
Yeah tried that out yesterday, and the noises were gone. They just appear when there is an audio connection from pro to the interface, did not matter if the pro is turned on or off. And of course the USB cable has to be connected.

Re: Pro 2 USB issues (Sound Glitches)
« Reply #5 on: March 16, 2016, 06:58:46 AM »
Ok, so it looks like it isn't a problem with the pro 2.

You have some kind of grounding issue going on, are the FF400, P2 and computer powered from a single wall socket?

Re: Pro 2 USB issues (Sound Glitches)
« Reply #6 on: March 17, 2016, 10:36:32 AM »
Yes, the Interface and monitors are on the same socket, the synths on a different one. I had grounding issues with my TT-303, it runs with 9V instead of 12V, but since i run it with batteries i have no more issues as well.

Re: Pro 2 USB issues (Sound Glitches)
« Reply #7 on: March 17, 2016, 12:03:21 PM »
A simple solution is probably to power everything off of the same socket, my bet is that it would cure the problem but that's not guaranteed.

If you can't do this you could use a DI box or some pseudo balanced leads from the unbalanced outputs of the P2 to the Balanced inputs of the FF800, this will get rid of the noise originating from the computers USB which is travelling through your P2 to the outputs.

There is a good page here about these sorts of issues: http://www.soundonsound.com/sos/nov04/articles/computerproblems.htm

Re: Pro 2 USB issues (Sound Glitches)
« Reply #8 on: March 24, 2016, 04:04:24 PM »
There is a good page here about these sorts of issues: http://www.soundonsound.com/sos/nov04/articles/computerproblems.htm

Hi Bob,

Thanks for linking to that page of mine  ;)

I suspect on this occasion that the OP may have a ground loop such as I described in this link:

www.soundonsound.com/sos/dec08/articles/qa1208_2.htm

i.e. Well, since his Pro 2 and computer are each earthed via their respective mains plugs, the ground loop is, on this occasion, completed via the USB cable that connects the two.

Some people have real problems with this scenario, since you can't remove the mains earth from either the synth or the computer for safety reasons.

One possible cure might be a USB isolator like this one on eBay:

http://www.ebay.co.uk/itm/like/221721409261?adgroupid=13585920426&hlpht=true&hlpv=2&rlsatarget=pla-131843274306&adtype=pla&ff3=1&lpid=122&poi=&ul_noapp=true&limghlpsr=true&googleloc=1007173&device=c&chn=ps&campaignid=207297426&crdt=0&ff12=67&ff11=ICEP3.0.0-L&ff14=122&viphx=1&ops=true&ff13=80

Hope this helps!


Martin

Re: Pro 2 USB issues (Sound Glitches)
« Reply #9 on: March 24, 2016, 11:44:29 PM »
Hi Martin,

I hadn't read the name of the author :)

Would the DI box still not cure the problem even if the loop is originating from the USB or do you have to break it in the USB cable?