The Official Sequential/DSI Forum

Howcan I turn off midi clock input?

Howcan I turn off midi clock input?
« on: August 18, 2019, 03:33:49 AM »
Just bought an OB6 desktop to go with my OB6 keyboard.  Very disappointed so far - it's very likely to get returned.
For one thing - I want to have the two synths run at different clock speeds and have simply got them connected by 5-pin midi, no patchbays, nothing just a wire.  Easy: set the desktop's Global MIDI Clock to Out.  No - it still follows the keytboard's tempo.  OK, set the desktop's Clock Port to USB.   No - it still follows the keytboard's tempo.  Is there a Global setting for 'do as you're told!'?

I've restarted both units (they are prone to ignore Global changes unless restarted).  Keyboard is running 1.5.5 and desktop 1.5.8.  Keyboard is set to MIDI Clock Out and Clock Port Midi.  If I change the keyboard's settings to Clock Off or port USB, the desktop still stays in sync!  Are these two things telepathic or are the global settings just for show?

So in summary I can change the desktop's tempo and they are now different but as soon as I change the keyboard's tempo, the desktop jumps to that tempo.  That's not 'Midi clock Off', it's 'Midi clock off until the other instrument changes so now I'll copy it'.
« Last Edit: August 18, 2019, 03:44:13 AM by Channelizer »

AlanC

Re: Howcan I turn off midi clock input?
« Reply #1 on: August 18, 2019, 08:40:48 AM »
Globals, top row, 3, Midi Clock = OFF should stop the arpeggiator / sequencer from syncing to incoming MIDI clock messages.

It certainly does on my keyboard, although I'm running OS 1.2.0.

Re: Howcan I turn off midi clock input?
« Reply #2 on: August 18, 2019, 09:53:44 AM »
Globals, top row, 3, Midi Clock = OFF should stop the arpeggiator / sequencer from syncing to incoming MIDI clock messages.

It certainly does on my keyboard, although I'm running OS 1.2.0.

You'd think that wouldn't you but its telepathy overrides any Global settings and keeps working.  With this set to OFF, changing the clock speed of the keyboard still changes the clock speed of the desktop!

AlanC

Re: Howcan I turn off midi clock input?
« Reply #3 on: August 18, 2019, 10:04:14 AM »
How about if you try turning off Param Xmit on the keyboard or Param Rcv on the module? That would stop changing the BPM on the keyboard from modifying the module.

Re: Howcan I turn off midi clock input?
« Reply #4 on: August 18, 2019, 12:08:44 PM »
How about if you try turning off Param Xmit on the keyboard or Param Rcv on the module? That would stop changing the BPM on the keyboard from modifying the module.

Yep that stops it receiving tempo changes.  It also stops it receiving all the other parameters I do want it to receive.  Turning the keyboard off at the mains works too ;-)

So when I turn off Clock In on the desktop, it does indeed stop receiving clock, but as soon as I turn the tempo knob on the keyboard, the desktop's knob is 'moved' to the same position, thereby changing the tempo.  This explains it then.