The Official Sequential/DSI Forum

Prophet 12 sending out random aftertouch data

Prophet 12 sending out random aftertouch data
« on: August 05, 2019, 03:39:00 PM »
Warning: I'm an idiot.
Sorry. :)

Mostly embarrassed because I couldn't find a [search] option and wondering if my security is too high on my browser (whut?).

So I'm finding that my Prophet 12 is sending out random aftertouch data.
wait, back up.

A few weeks ago I saw that my Prophet 12 was sending random aftertouch data about 60% of the time it was on and the whole rig was on. Almost always values 0x2B-2E

Note: I use MIDI Translator Pro to route and process data so I see the data coming from the Prophet. Duplicatable in MIDIOx

So, after creating a Profile here and finally getting around to asking this question, i went to get the hard data (specific CCs, values, etc) and noticed the Prophet is now also sending out Pitch Bend and CC 9,72. & 73.  (I hadn't noticed this before, which does NOT indicate that it hadnt)

Everything is idle.
Everything as only been powered on.

The scripts I use in MTPro only translate button input from a Behringer button box, some numbers crunched, and then some CC msgs are generated destined for a Squarp Pyramid. The Prophet is no where in that active system.

This issue seems intermittent, but it's not as easy as just rebooting and everything is fine.

I have no clue how to attempt to start troubleshooting this.
I'm using OS 1.4.0

Help...maybe.  Whut?

Re: Prophet 12 sending out random aftertouch data
« Reply #1 on: January 07, 2020, 10:14:18 AM »
So, this doesnt happen with anyone else?

Im so frustrated - i know its minor but "support" refused assitance. Ive tried different cables, tried different destinations (mostly computers with MIDIOx), etc.

I run some very complex (for me) MTPro scripts to do a bunch of logic stuff to run sequencers and that constant data from the Prophet nakes it very frustrating to troubleshoot. Im already handicapped by idiocy.

Re: Prophet 12 sending out random aftertouch data
« Reply #2 on: January 10, 2020, 05:44:30 AM »
 It sounds like there may be a either 1)a physical issue with your AT strip or, most likley 2) The controllers need to be calibrated.
 Why did DSI refuse support?!

 You tried reinstalling firmware and running a calibration of wheels and sliders?
 Have you tracked down which hard knobs are sending the errant CC data and twiddle them?
 Have you exercised each key's aftertouch travel and played with the aftertouch response settings?

 These are a few suggestions that may or may not help.
 I find on my P12 that when I have the knobs set to hook, they sometimes cannot find the digital setting until I twiddle the detended knob at the panel. It seems there may be a internal calibration issue with that. This same issue may also cause a misfire of data as well. That being said, I am not a software designer in any way.


Re: Prophet 12 sending out random aftertouch data
« Reply #3 on: January 12, 2020, 03:26:26 PM »
Thank you Thank you Thank you for responding!

First thing I tried was upgrading the OS, since I noticed there was a newer version out. That counts for reinstalling the firmware, perhaps? Or is there a routine for wiping it and installing a fresh copy of the OS (like NVidia video card drivers)?

Ran the calibrations, yup.

I'm thinking it's not a hard knob because the data being sent is [DA vv] where vv is usually oscillating at random intervals between a small number of values. Right now it's just going back and forth between 2A and 28, just in irregular spurts.  (nothing nothing nothing then 6-8 messages, then nothing nothing nothing, then like 20, etc)

Also, it is sending out DA (Prophet is on Channel 11). Umm...I'm not terribly knowledgeable but I'm under the impression that D indicates it's Channel Pressure/Aftertouch and I can't find any reference to another MIDI message that starts with D.

I have tried all knob modes, but this only happens with Aftertouch messages and occurs in all knob modes.

I've also tried multiple USB cables.

Note: I'm using USB MIDI. Years of fighting against USB MIDI and I finally drank the Kool Aid. (Had some overly dramatic jitter issues early on, but these are now resolved. heh)

However, running a quick test over the last few minutes indicates I'm not getting the same issue with DIN MIDI. This would make it seem to me like the problem is something either hardware or software between the conversion of data in/out routing to USB MIDI that does not exist on the DIN MIDI side.

I'll have to stick to my workaround which is just turning off AT. I find nerfing a feature to get a basic function operable to be ridiculous, but that's where I'm at, alas.

I appreciate your response.
Thank you for your suggestions!