The Official Sequential/DSI Forum

Can't power on new Tempest

Can't power on new Tempest
« on: May 27, 2019, 10:18:51 AM »
Hello everybody!

I just received my Tempest, but for some reason it won't turn on...

I plugin the power adaptor, a set of headphones and hit the on/off switch.... and nothing happens.

Am I missing something really stupid or have I received a broken model?

Thanks!

Edit:

Looks like the power supply is faulty  :( I tried the power supply of my modem and the Tempest powered on immediately...
« Last Edit: May 27, 2019, 10:56:12 AM by hessel »

Re: Can't power on new Tempest
« Reply #1 on: May 28, 2019, 12:13:48 AM »
Welcome on board!Sorry to hear youíre having troubles with your Tempest.You should contact support so they can send you a new power supply..Iíve seen this issue before and i was about to send you a reply but youíve already figured this out I see..
Looks like the power supply is faulty  :( I tried the power supply of my modem and the Tempest powered on immediately...

Re: Can't power on new Tempest
« Reply #2 on: May 28, 2019, 02:45:46 AM »
Welcome on board!Sorry to hear youíre having troubles with your Tempest.You should contact support so they can send you a new power supply..Iíve seen this issue before and i was about to send you a reply but youíve already figured this out I see..
Looks like the power supply is faulty  :( I tried the power supply of my modem and the Tempest powered on immediately...

Thanks! I contacted my local shop and they will arrange a replacement power supply. In the meantime I ordered a suitable psu (https://www.allekabels.nl/na/0/1098350/universele-ac-dc-adapter.html) so I can start using the Tempest tomorrow  ;D

Re: Can't power on new Tempest
« Reply #3 on: May 28, 2019, 06:33:35 AM »
Nice work!
Have fun!
Welcome on board!Sorry to hear youíre having troubles with your Tempest.You should contact support so they can send you a new power supply..Iíve seen this issue before and i was about to send you a reply but youíve already figured this out I see..
Looks like the power supply is faulty  :( I tried the power supply of my modem and the Tempest powered on immediately...

Thanks! I contacted my local shop and they will arrange a replacement power supply. In the meantime I ordered a suitable psu (https://www.allekabels.nl/na/0/1098350/universele-ac-dc-adapter.html) so I can start using the Tempest tomorrow  ;D

Re: Can't power on new Tempest
« Reply #4 on: May 29, 2019, 08:05:21 AM »
Anyone knows if this psu will be safe to use? https://www.allekabels.nl/na/0/1098350/universele-ac-dc-adapter.html

AC/DC Adapter
100-240 V AC, 50/60 Hz
15V DC
1.5 A