The Official Sequential/DSI Forum

OB6 MPE

mafi

Re: OB6 MPE
« Reply #100 on: January 05, 2021, 09:06:16 AM »
This is amazing, MPE for the OB-6. Sequential, thank you so much! I can't find instructions for using it, though.
So I guess pitch bend is just going to work, and pressure or poly AT will use the aftertouch routing.
What about the Y-axis / expression dimension? How do I assign that?
Thanks

mafi

Re: OB6 MPE
« Reply #101 on: January 05, 2021, 09:56:56 AM »
Ah, I just give the right CC# to send from the controller (LinnStrument). D'oh!
The pitch bend range seems stuck on 1 semitone, though. Vibrato is possible, but glissandos >1 semitone don't work for me.

the8bitdeity

  • *
  • 33
  • Ham handed synth enthusiast
Re: OB6 MPE
« Reply #102 on: January 05, 2021, 11:17:18 AM »
This is amazing, MPE for the OB-6. Sequential, thank you so much! I can't find instructions for using it, though.
So I guess pitch bend is just going to work, and pressure or poly AT will use the aftertouch routing.
What about the Y-axis / expression dimension? How do I assign that?
Thanks

OB6 has always responded to Polyphonic Aftertouch, now however you get a new modulation in the form the Y-Axis controller (which is CC74). You'll need something capable of MPE transmission to take advantage of it (like the new Live beta or Bitwig for software, or some other MPE controllers like the Roli or the Linnstrument)
P12R, uWXT, Kijimi, Xerxes, OB6D, P6D, Hydrasynth, System 8, Pro 3, Wavestate, Peak, MS20D, A4mk2, ARmk2, MC202, Avalon, Model:Cycles, Octatrack, NLDR, H9000, Digitone, Deckard's Dream mk2, Roland System 500 + other Eurorack

Re: OB6 MPE
« Reply #103 on: January 05, 2021, 07:36:30 PM »
Spent all night on this - cannot update.  Tried both USB and Midi interface, two different computers, one with windows 10, all buffer configurations.  I've done updates before on OB6.   Using Midi Ox (two different versions even), etc......   never had such difficulty before updating any instrument.  Countdown always ends before green bar, no matter what.   Any suggestions?
« Last Edit: January 05, 2021, 07:41:53 PM by Soundquest »
Sequential Equipment: Poly Evolver Keyboard, Evolver desktop,   Pro-2, OB6, P-12
 

https://Soundcloud.com/wavescape-1

pfrf

Re: OB6 MPE
« Reply #104 on: January 05, 2021, 09:11:32 PM »
I posted this in another thread, maybe it will help you.  I followed these directions after a few frustrating hours of getting nowhere, and it worked:

I got this information from something a Sequential employee posted at GS:

"I would try updating to the synth via the bootloader. Hold WRITE while powering on. An animation will be shown on one of the screens indicating that bootloader is active. Send the OS to the synth via the MIDI IN port (USB cannot be used in bootloader mode)."

There's an extra light show near the end of the process when updating this way, so don't touch the synth for a minute or two after you reach 000 on the countdown.

Good luck, I feel your pain.

mafi

Re: OB6 MPE
« Reply #105 on: January 06, 2021, 06:04:45 AM »
I guess you know this, but apparently slowing the transmission rate of the sysex file can solve problems like this.
It worked for me, but the OB6 didn't reboot at the end, it just sat there with '0' on the display. Powering down manually was fine and it worked OK.

mafi

Re: OB6 MPE
« Reply #106 on: January 06, 2021, 06:25:38 AM »
Current issues I'm having with this 1.6.4 beta OS:
- pitch bend range seems to be stuck on just under 1 semitone, regardless of panel setting;
- sending CC to osc 2 level or PW results in non-polyphonic behaviour - all voices respond to a single voice's CC;
- grittiness / roughness to the sound when CCs are flowing, some CCs worse than others, eg. y-axis (LinnStrument) -> osc 1 PW

The grittiness sounds like anti-alliasing of the CC data which needs smoothing / filtering, though I guess it could be the digital hardware maxing out under unprecedented demands. Hopefully it's alliasing!

Another thing. I know the osc frequency controls are quantised to semitones on the panel. This quantisation is also present when controlling osc freq via CC. It would be nice, if possible, to have the option of smoothish sweeping of the frequency of osc 1 in particular, for smooth osc sync effects. Having the expression dimension of MPE subtly controlling the pitch of an oscillator which is sync'ed can work very nicely, IME, sounding very natural.

Thanks again for for such a brilliant development in a 5 year old synth. You guys are stars! Good luck with the final version.

Re: OB6 MPE
« Reply #107 on: January 06, 2021, 08:50:29 AM »
Thanks guys,  I'll give it another shot tonight.
Sequential Equipment: Poly Evolver Keyboard, Evolver desktop,   Pro-2, OB6, P-12
 

https://Soundcloud.com/wavescape-1

PhJ

Re: OB6 MPE
« Reply #108 on: January 06, 2021, 12:28:19 PM »
It works here with a Rise49, thanks a lot Pym & Sequential !

mafi

Re: OB6 MPE
« Reply #109 on: January 07, 2021, 12:22:10 PM »
Happy days

  https://www.youtube.com/watch?v=xxYuANn7tJM]https://www.youtube.com/watch?v=xxYuANn7tJM

I don't know what that ] at the beginning of the url is doing. Obviously don't paste that into your browser.
« Last Edit: January 07, 2021, 12:27:20 PM by mafi »

Re: OB6 MPE
« Reply #110 on: January 09, 2021, 08:18:10 AM »
I posted this in another thread, maybe it will help you.  I followed these directions after a few frustrating hours of getting nowhere, and it worked:

I got this information from something a Sequential employee posted at GS:

"I would try updating to the synth via the bootloader. Hold WRITE while powering on. An animation will be shown on one of the screens indicating that bootloader is active. Send the OS to the synth via the MIDI IN port (USB cannot be used in bootloader mode)."


There's an extra light show near the end of the process when updating this way, so don't touch the synth for a minute or two after you reach 000 on the countdown.

Good luck, I feel your pain.


Thank you.  This alternate OS loading technique worked first try using midiox, 1024 buffer speed, and a Roland UM midi interface cable.
« Last Edit: January 09, 2021, 08:33:32 AM by Soundquest »
Sequential Equipment: Poly Evolver Keyboard, Evolver desktop,   Pro-2, OB6, P-12
 

https://Soundcloud.com/wavescape-1

Re: OB6 MPE
« Reply #111 on: January 09, 2021, 08:31:53 AM »
Current issues I'm having with this 1.6.4 beta OS:
- pitch bend range seems to be stuck on just under 1 semitone, regardless of panel setting;
- sending CC to osc 2 level or PW results in non-polyphonic behaviour - all voices respond to a single voice's CC;
- grittiness / roughness to the sound when CCs are flowing, some CCs worse than others, eg. y-axis (LinnStrument) -> osc 1 PW

The grittiness sounds like anti-alliasing of the CC data which needs smoothing / filtering, though I guess it could be the digital hardware maxing out under unprecedented demands. Hopefully it's alliasing!

Another thing. I know the osc frequency controls are quantised to semitones on the panel. This quantisation is also present when controlling osc freq via CC. It would be nice, if possible, to have the option of smoothish sweeping of the frequency of osc 1 in particular, for smooth osc sync effects. Having the expression dimension of MPE subtly controlling the pitch of an oscillator which is sync'ed can work very nicely, IME, sounding very natural.

Thanks again for for such a brilliant development in a 5 year old synth. You guys are stars! Good luck with the final version.

Glad to have the update and the vintage feature too.  Thanks Sequential!     I too had thought that when playing more than one note at once that pitch slides are stepped, instead of smooth.  But later I realized I was set up wrong on the Linn.  Make sure you set it at Ch per note in the split settings menu. Select just channels 2 thru 7.    Also, make sure your modwheel on OB6 itself is down all the way.
« Last Edit: January 09, 2021, 09:24:49 AM by Soundquest »
Sequential Equipment: Poly Evolver Keyboard, Evolver desktop,   Pro-2, OB6, P-12
 

https://Soundcloud.com/wavescape-1

Re: OB6 MPE
« Reply #112 on: January 10, 2021, 01:28:46 AM »
A big thank you to Dave and the Sequential team for this fantastic update ! Vintage control is awesome, turns both OB-6 and P6 into new, even more inspiring synths. MPE is a game changer too ... some little glitches here and there on my configuration (Seaboard Rise 25 via MacBook Pro 2014 running Mojave connected via USB 3.0 hub to a MOTU Micro Lite MIDI interface, update went smoothly on both P6 and OB-6 with SysEx Librarian on default settings): Had to recalibrate a few times as it seemed that some voices had gotten ‘stuck’ on different basic tuning/filter frequency ... no big deal.
Remember: For MPE, one needs to set the max. number of channels on the controller to 6, otherwise one will loose notes (took me a while to figure it out).

Again: THANK YOU !!!

Re: OB6 MPE
« Reply #113 on: January 10, 2021, 03:16:07 PM »
Using Linn instrument If your OB6 is in MPE mode and you are entering notes from the controller into sequencer you need to set Linn to one channel out , otherwise it wont recognize chords sent, only single notes.  Also,  is using OB6 sequencer and Linn, there are some hanging notes that develop after doing a pitch slide whereas the whole sequence will transpose a bit. To rectify the event switch out of MPE and back to MPE mode, or tap 6 successive same notes which corrects it.    Its like a hanging midi message transposing the sequencer. 

I haven't noticed any other issues.
Sequential Equipment: Poly Evolver Keyboard, Evolver desktop,   Pro-2, OB6, P-12
 

https://Soundcloud.com/wavescape-1

Re: OB6 MPE
« Reply #114 on: January 10, 2021, 06:22:18 PM »
Installed the new update, but when choosing MPE in midi channels, the pitchbend range doesn’t line up with what I selected.
Both Linnstrument & ob6 are set to a +/- 12 range.
The bend range works fine when mpe is not selected.

-edit- sorted with the global bendrange

What did you do, if you don't mind me asking. I can't get it to work at all on my Prophet 6. Seems like only global pitch is being taken from my Rise 49.
You can't make everybody happy, but you can make everyone miserable.

mafi

Re: OB6 MPE
« Reply #115 on: January 11, 2021, 01:14:35 AM »
Installed the new update, but when choosing MPE in midi channels, the pitchbend range doesn’t line up with what I selected.
Both Linnstrument & ob6 are set to a +/- 12 range.
The bend range works fine when mpe is not selected.

-edit- sorted with the global bendrange

What did you do, if you don't mind me asking. I can't get it to work at all on my Prophet 6. Seems like only global pitch is being taken from my Rise 49.
I haven't tried it yet, but on the OB-6 the pitch bend needs to be set in the new Global settings rather than the usual way with the wheel bend range button.

Re: OB6 MPE
« Reply #116 on: January 12, 2021, 04:42:39 PM »
Anybody try this yet with a Sensel Morph??
DSI OB-6, Nord Electro 3HP & 6HP, Roland SoundCanvas SC55mkii, Beatstep Pro, KeyStep, Roland SE-02, MPD18 (+mpcstuff), Roland TD-4 V-drums, Fender-Rhodes Stage MK1, Reaper, plus dozens of acoustic instruments

Re: OB6 MPE
« Reply #117 on: January 12, 2021, 05:53:29 PM »
Ah, I just give the right CC# to send from the controller (LinnStrument). D'oh!
The pitch bend range seems stuck on 1 semitone, though. Vibrato is possible, but glissandos >1 semitone don't work for me.

Also trying to set up a LinnStrument, can you please elaborate and confirm what's worked for you?

midi mode>channel per note, per note channels 2-7?   
« Last Edit: January 12, 2021, 06:01:09 PM by sinuendo »

Re: OB6 MPE
« Reply #118 on: January 13, 2021, 03:07:53 AM »
Installed the new update, but when choosing MPE in midi channels, the pitchbend range doesn’t line up with what I selected.
Both Linnstrument & ob6 are set to a +/- 12 range.
The bend range works fine when mpe is not selected.

-edit- sorted with the global bendrange

What did you do, if you don't mind me asking. I can't get it to work at all on my Prophet 6. Seems like only global pitch is being taken from my Rise 49.
I haven't tried it yet, but on the OB-6 the pitch bend needs to be set in the new Global settings rather than the usual way with the wheel bend range button.
Press bank + global to get into the new menu

mafi

Re: OB6 MPE
« Reply #119 on: January 13, 2021, 05:51:34 AM »
Ah, I just give the right CC# to send from the controller (LinnStrument). D'oh!
The pitch bend range seems stuck on 1 semitone, though. Vibrato is possible, but glissandos >1 semitone don't work for me.

Also trying to set up a LinnStrument, can you please elaborate and confirm what's worked for you?

midi mode>channel per note, per note channels 2-7?   
Please read earlier posts, the proper way is to use the 3rd "row" of global settings, although it is possible to send the y-axis directly via CC to OB-6s parameters. Most params give glitchiness but osc level worked ok for me (y-axis to CC77 was what I used in the video)