The Official Sequential/DSI Forum

Auditioning patches from MIDI

Auditioning patches from MIDI
« on: November 13, 2018, 06:48:44 AM »
While attempting to audition patches by selecting a new patch on the DAW MIDI track, often the PX will display the patch but either play nothing or the previous patch. This occurs very often. I understand that the programs take a while to load. They never actually show up though.

Local control is OFF.

When local is off it would be handy to have the PX send program change.

Re: Auditioning patches from MIDI
« Reply #1 on: November 13, 2018, 10:40:51 AM »
When Local Control is set to ALL OFF, transmitted program change commands must be routed back into the synth in order for the program to actually change. So, my guess would be that when this occurs for you, you don't have the transmitted MIDI looping back into the synth.

If you used MIDI monitoring software, you can see that program change commands are transmitted when Local Control is OFF. If this is not occurring for you, please check that the MIDI Program Send global is set to ON.
SEQUENTIAL

Re: Auditioning patches from MIDI
« Reply #2 on: November 13, 2018, 11:51:15 AM »
I am sending the program change commands from the DAW with the PX in the local off mode. It is more convenient to work with local off so I can leave DAW MIDI output routed to the PX while recording. The problem is that the program changes get to the PX fine but even though the program name comes up, often the PX is playing the wrong program or none at all.

Re: Auditioning patches from MIDI
« Reply #3 on: November 13, 2018, 11:58:19 AM »
It is kind of a different issue but when local control is off, it seems that no program change commands are transmitted.

cbmd

  • *****
  • 291
    • Sequential
Re: Auditioning patches from MIDI
« Reply #4 on: November 13, 2018, 12:03:31 PM »
I've just checked a Prophet X in shop.  With local control off, and program send on, program changes are being transmitted to the MIDI output.
Sequential

Re: Auditioning patches from MIDI
« Reply #5 on: November 13, 2018, 01:01:50 PM »
Oh Snafu. Program Send. I had thought it was sending program changes with  local on and Program Send off so I just passed that up thinking it had been set on. It must have been sending controls instead.  Sweet. That's helpful. Sorry you had to take the time to do that. I do have some trouble reading the global menu sometimes. 

Any ideas on the other problem I am seeing?