The Official Sequential/DSI Forum

Filter circuit broken [SOLVED]

Filter circuit broken [SOLVED]
« on: September 10, 2018, 12:35:46 PM »
It appears my low pass filter circuit has stopped working.  I've opened a support case but just want to do a sanity check with the community.  To troubleshoot:

- Initialize the basic patch
- Turn the filter cutoff knob.
- Filter should be responding but in my unit it is not.  I can see the knob does work as the screen updates.

I didn't miss anything did I?

Interestingly, if I assign an LFO to the filter cutoff I get a "small" amount of filter cutoff response but I have to crank it to near maximum.

This looks like a broken filter circuit to me.
« Last Edit: September 10, 2018, 04:15:57 PM by extempo »
Quantum | Montage 7 | Moog One | 14u x 104hp Eurorack | H9000 | SoundCraft GB4 24 Mixer | MixPre 10T

dslsynth

  • ***
  • 1036
Re: Filter circuit broken
« Reply #1 on: September 10, 2018, 12:40:09 PM »
Two sources of potential fun here: (1) Pot mode global parameter. (2) Sample oscillator filter bypass.
#!/bin/sh
cp -f $0 $HOME/.signature

Re: Filter circuit broken
« Reply #2 on: September 10, 2018, 12:53:37 PM »
Two sources of potential fun here: (1) Pot mode global parameter. (2) Sample oscillator filter bypass.

Thank you for your input.

When you initialize a patch the sample instruments aren't even turned on so that is definitely not it.  The digital oscillators can't bypass the filter so they should be affected.

The Pot mode also doesn't matter.  I am throwing the filter cutoff knob through its entire range to no effect.
Quantum | Montage 7 | Moog One | 14u x 104hp Eurorack | H9000 | SoundCraft GB4 24 Mixer | MixPre 10T

dslsynth

  • ***
  • 1036
Re: Filter circuit broken
« Reply #3 on: September 10, 2018, 01:15:06 PM »
At least you did check it as especially pot mode can be confusing if user is unaware of current setting.

Good luck with the process. I am sure it can be resolved fairly fast.
#!/bin/sh
cp -f $0 $HOME/.signature

dslsynth

  • ***
  • 1036
Re: Filter circuit broken
« Reply #4 on: September 10, 2018, 02:53:34 PM »
The Pot mode also doesn't matter.  I am throwing the filter cutoff knob through its entire range to no effect.

What is the default oscillator wave shape?
#!/bin/sh
cp -f $0 $HOME/.signature

Re: Filter circuit broken
« Reply #5 on: September 10, 2018, 03:01:12 PM »
The Pot mode also doesn't matter.  I am throwing the filter cutoff knob through its entire range to no effect.

What is the default oscillator wave shape?

Sawtooth
Quantum | Montage 7 | Moog One | 14u x 104hp Eurorack | H9000 | SoundCraft GB4 24 Mixer | MixPre 10T

Re: Filter circuit broken
« Reply #6 on: September 10, 2018, 03:41:21 PM »
Wow.

So as it turns out, the Expression pedal by default control the filter cutoff.  This isn't something I would ever set myself which is why I didn't notice it.  As soon as I disconnected the expression pedal (or changed it to something else) the filter started working again. 

 ;D   ??? ::)  8)

I have 4 other DSI synths and never noticed this setting before, probably because I've never bothered with a foot pedal before.
Quantum | Montage 7 | Moog One | 14u x 104hp Eurorack | H9000 | SoundCraft GB4 24 Mixer | MixPre 10T