The Official Sequential/DSI Forum

Pro 2 BETA 1.4.0.1 Bug reports

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #40 on: August 04, 2018, 09:46:09 AM »
Not a bug:

The ARP Beat Sync is a long time coming. Could it be implemented for the sequencer as well? We can't always be 'on time' when playing back a sequence and key transposing ;) Or at least buffer change , or ensure sequence plays till end before transpose...however way you want...BEAT SYNC for the Sequencer as an option. ..Thank you.

cbmd

  • *****
  • 219
    • Dave Smith Instruments
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #41 on: August 04, 2018, 12:56:46 PM »
Try turning RESTART OFF in the sequencer parameters.  This will assure the sequence doesn't restart when you hit a key off time when transposing the sequence.
Dave Smith Instruments

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #42 on: August 05, 2018, 04:37:16 AM »
Hey,

The screen will not update to indicate the reception of the alternate tunings.  If they were loaded correctly, there should be 17 different tunings available to select from.

I'm having problems with the new tunings ...

In Globals I have an entry for "26. Scale (Alt Tunings)" and if I scroll through them all  there are 17 numbered entries but all the titles are the blank except the first which says "1. Equal Temperment"

If I select any of the tunings apart from the first, the tuning is the same but the timbre is different - kind of muffled with lots of highs/mids missing and quiet (with the program I was testing it on_.

I updated the o/s first and then tunings.

thanks

« Last Edit: August 05, 2018, 04:43:08 AM by apwynne »

cbmd

  • *****
  • 219
    • Dave Smith Instruments
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #43 on: August 05, 2018, 03:15:54 PM »
Double check that your Sysex Cable global parameter is set to the correct port (MIDI or USB).  Try closing/reopening sysex librarian/midi ox and try the transmission again.
Dave Smith Instruments

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #44 on: August 06, 2018, 09:47:34 AM »
Thanks!
Alt scales now showing up in Globals :)

Double check that your Sysex Cable global parameter is set to the correct port (MIDI or USB).  Try closing/reopening sysex librarian/midi ox and try the transmission again.

blewis

  • **
  • 134
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #45 on: August 06, 2018, 07:56:10 PM »
I know this is my own pet feature that I want, so take this "bug report" FWIW.

I still can't get the sequencer to act as a pure control sequencer when in paraphonic mode. In Mono mode, I think it's working fine.

From what I can tell, when the Sequencer is enabled, it's like it is reserving a note to itself - even if I have Notes: Off on Track 1.

Use this experiment on a factory paraphonic patch Cascades P2 F5. Play a 4 note paraphonic chord. Nice isn't it?

Now enable the Sequencer. Select Track 1. Turn Notes: Off. My expected behavior is that Track 1 will not affect the notes of the synth engine.

Press play.  Here that sequencer taking over a note? You can hear a sustained note.

Turn the level of all oscillators down - all to zero. The note is still there. In fact, its the Sub of Osc 1 that is sounding. The Sequencer, some how, is opening the envelope of just the sub of OSC 1?  What?

The destinations of all sequencer tracks is None on this factory patch. As far as I can tell, the Sub of OSC1 is not a destination in the mod matrix.

So, needless to say, this is breaking paraphonic mode when the sequencer is enabled.

It's like the Sequencer is reserving a note even if I set Notes: Off. And it appears to be reserving the Sub?

It's weird. Try to play that 4 note chord with the sequencer on.  It's totally wrong. Turn sequencer off, then play your chord, then back on etc... When the sequencer is on, you'll hear that Sub sticking to the lowest note that has been played since the sequencer was enabled.

Closer, but it still doesn't work the way I am hoping we can get it to work.

When in paraphonic mode, the Pro2 seems smart about what note it's going to assign to OSC1, because OSC1 has the sub it seems to dynamically assign the lowest note to that oscillator.  Seems pretty smart.

But when the sequencer is playing, even with Notes: Off, Mute: On/Off, it's like the Sequencer has reserved the Sub or the voice with the sub, or the priority is all out of whack. Feels like I'm playing with 2 or 3 paraphonic voices.

Very confusing.
« Last Edit: August 06, 2018, 08:07:54 PM by blewis »

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #46 on: August 06, 2018, 08:01:58 PM »
Alt tunings file will not load. 1.3.1.23 loaded, sysex enabled via usb. Tried restarting sysex librarian application. Send file shows no status on pro2 display, no tunings loaded, just equal temperment and all the others are blank.

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #47 on: August 07, 2018, 06:14:17 AM »
Alt tunings file will not load. 1.3.1.23 loaded, sysex enabled via usb. Tried restarting sysex librarian application. Send file shows no status on pro2 display, no tunings loaded, just equal temperment and all the others are blank.

Do you have a specific MIDI channel set for your Pro2? One of the things I did to mine was set channel to 'All' before sending tunings.syx. Not sure if that did it but it worked in the end.

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #48 on: August 07, 2018, 09:02:49 AM »
I am not convinced the Tuning file is loading correctly. I too had similar problems but eventually got it to load. However, it seems the display names in ‘Global / 26. Scale (Alt Tuning)’ window are not correct, and who knows if any other bits and bytes have gone astray.

Scales:
1. Equal Temperament
2. Harmonic Series
3. Carlos Harmonic Twelve Tone
4. Meantone Temperament
5. 1/4-Tone Equal Temperament
6. 19-Tone Equal Temperament
7. 31-Tone Equal Temperament
8. Pythagorean C
9. Just Intonation in A with 7-limit Tritone at D#
10. 3-5 Lattice in A
11. 3-7 Lattice in A
12. Other Music 7-Limit Black Keys in C
13. Dan Schmidt Pelog/Slendro
14. Yamaha Just Major C
15. Yamaha Just Minor C
16. Harry Partch 11-limit 43 Note Just Intonation
17. Arabic 12-Tone

Displayed Name:
1. Equal Temperament
2. HrmA1-60
3. HrmA-12T
4. Meantone.3
5. 1/4TonET.4
6.19ToneET.5
7. 31ToneET.6
8. PythagoC.7
9. JIA7/5D#.8
10. 3-5LattA.9
11. 3-7LattA.10
12. 7.LimBlkC.11
13. PelSlenB.12
14. JIMajYam.13
15. JIMinYam.14
16. Partch11.15
17. Arabian C

Correct Name:
1. Equal Temperament
2. HrmA1-60
3. HrmA-12T
4. Meantone
5. 1/4TonET
6.19ToneET
7. 31ToneET
8. PythagoC
9. JIA7/5D#
10. 3-5LattA
11. 3-7LattA
12. 7.LimBlkC
13. PelSlenB
14. JIMajYam
15. JIMinYam
16. Partch11
17. Arabian C
      

cbmd

  • *****
  • 219
    • Dave Smith Instruments
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #49 on: August 07, 2018, 11:13:07 AM »
That's just a display bug.  On our list!
Dave Smith Instruments

cbmd

  • *****
  • 219
    • Dave Smith Instruments
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #50 on: August 07, 2018, 06:12:35 PM »
Turns out the naming issue was literally mis naming in the file itself.  A new Alt tunings file has been loaded to the OS download thread which fixes the names.

Thanks!
Dave Smith Instruments

jg666

  • **
  • 209
Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #51 on: August 07, 2018, 10:28:55 PM »
Probably a dumb question but I'll ask anyway :)

I've not bothered loading the alt tunings as I can't see me needing them, would that be a problem? Are these tunings an optional extra or should I go ahead and load them?
DSI Prophet Rev2, DSI Pro 2, Moog Sub37, Korg Minilogue, Yamaha MOXF6

mosen

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #52 on: August 08, 2018, 04:09:49 AM »
Don`t know if this is bug or a feature:

I wonder why a OSC FM Setting of 255 is not the max?
You can push this by adding modsources to it (Slider or DC pushes the FM amount further).
Can`t we dial in max fm amount without using several mod sources?

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #53 on: August 08, 2018, 03:55:46 PM »
Are these tunings an optional extra or should I go ahead and load them?

Completely optional. Won't hurt anything if you don't load them.
SEQUENTIAL

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #54 on: August 08, 2018, 03:58:29 PM »
Can`t we dial in max fm amount without using several mod sources?

The intended max value of a given parameter is the amount you can get to using the knob. We allow for extra range through the mod matrix as a way to push things outside "normal" operation if so desired, thus extending the sonic possibilities.
SEQUENTIAL

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #55 on: August 08, 2018, 05:10:19 PM »
Try turning RESTART OFF in the sequencer parameters.  This will assure the sequence doesn't restart when you hit a key off time when transposing the sequence.

I had an opportunity to test this tonight. It's not as bullet proof as the new ARP BEAT SYNC. Be cool if it could be.

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #56 on: August 09, 2018, 12:49:27 PM »
We know the program name does not update when locking the sequence (great feature from the Evolver btw!)

It would be great if on the program screen it displayed the locked sequence bank and program numbers in the soft button 3 location or elsewhere.

mosen

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #57 on: August 10, 2018, 09:54:32 AM »
Can`t we dial in max fm amount without using several mod sources?

The intended max value of a given parameter is the amount you can get to using the knob. We allow for extra range through the mod matrix as a way to push things outside "normal" operation if so desired, thus extending the sonic possibilities.

this makes kind of sense - your sense  ;D
Love the Pro2

Re: Pro 2 BETA 1.3.1.23 Bug reports
« Reply #58 on: August 10, 2018, 02:23:22 PM »
Can`t we dial in max fm amount without using several mod sources?

The intended max value of a given parameter is the amount you can get to using the knob. We allow for extra range through the mod matrix as a way to push things outside "normal" operation if so desired, thus extending the sonic possibilities.

this makes kind of sense - your sense  ;D
Love the Pro2

Agreed.

https://youtu.be/4xgx4k83zzc

Re: Pro 2 BETA 1.3.1.30 Bug reports
« Reply #59 on: August 10, 2018, 08:05:10 PM »
Hi, I have a few bugs so far and will continue to post links of what I find as I come across things.

1. I am not sure if this is a bug but it sure behaves different to what I would expect. I am trying to sequence and control my  moog dfam (osc 1 of dfam) via gate and cv out from the dsi pro 2 sequencer. now i setup the correct settings in menu like 'keytrack 127 to cv out 1' and then 'dc -64 to cv out 1' and when i record via the keyboard a sequencer pattern into seq track 1 the pro 2 and dfam play the same notes when I have the volume of both up. now my problem is that when I go into seq 1 on pro 2 and 'mute' the track..it no longer sends gate or sequences the dfam. I want to sequence my dfam from track 1 and be able to do other stuff on the pro 2 without it also playing the same sequence. I try other things like copying the seq 1 track to another track which i make cv 1 out..but now the 2 tracks add in cv voltage and now the dfam plays almost out of range..If you could investigate this Carlsen and try out some stuff similar I think you will know what I mean. Also I tried sequencing my moog sub 37 via midi out channels from sequencer and the having the midi all selected in the global menu didn't pick up the sub37. I'll have to try the midi sequencing out again but I remember that it worked before update now something with the midi sequencing didn't work. If you could investigate this also Carlsen that would be great. I will post more if I find more bugs. Cheers and thanks :)