The Official Sequential/DSI Forum

Pro 2 BETA 1.4.0.5 Bug reports

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #120 on: January 16, 2020, 12:34:40 AM »
Hi,

Where can I download the latest version (1.4.0.5)?

I've installed 1.4 from 1.3 and I have a bug to report: the Alternate Tuning doesn't appear to work as the options in the Global menu only show numbers (up to 17) after the Equal Temperament setting, and they don't allow the patches to play properly.

I've reset the Global settings and unplugged USB cable.

Please advise!

I love this synth!

:-)

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #121 on: January 16, 2020, 01:47:26 AM »
Hi,

Where can I download the latest version (1.4.0.5)?

You'll find the latest version over here: https://forum.sequential.com/index.php/topic,1223.0.html

blewis

  • **
  • 218
Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #122 on: January 26, 2020, 05:17:47 AM »
Paraphonic sequencing sent to an external poly synth is resulting in hung notes all over the place in reverse, random, and ping pong modes. Works as expected in forward mode.

In this configuration, the alternate playback directions can only be used as a special effect as the target synth quickly reaches a sustained mess.

External synth is a single timbre on a Novation Summit.

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #123 on: May 01, 2020, 05:47:10 AM »
Hello

I recently update to the newest firmware, and some of my patches with sequences sound different.
Any idea why, or how to fix it?

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #124 on: May 01, 2020, 08:32:36 AM »
Hello

I recently update to the newest firmware, and some of my patches with sequences sound different.
Any idea why, or how to fix it?

could you specify in which way they sound different?
Like individual notes and their pitch being different or just the sound/timbre of them?

When I encounter this I check with a basic sawtooth patch weather the filters are working right. And if there happen to be slopes in the filter curve I recalibrate them (up to 5 times in a row testing).

Especially with resonance this can change the whole flavor of a sequence.

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #125 on: May 01, 2020, 02:10:58 AM »
Hello

I recently update to the newest firmware, and some of my patches with sequences sound different.
Any idea why, or how to fix it?

could you specify in which way they sound different?
Like individual notes and their pitch being different or just the sound/timbre of them?

When I encounter this I check with a basic sawtooth patch weather the filters are working right. And if there happen to be slopes in the filter curve I recalibrate them (up to 5 times in a row testing).

Especially with resonance this can change the whole flavor of a sequence.

The sequence was a highly altered edit of a preset. There are crunchy tones where there were once smooth tones. I have checked every sequence for what may be causing it. I haven't had any luck. I recalibrated everything, but not the filter curves. The filters seems to be fine. I was a dummy for not backing everything up.

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #126 on: May 01, 2020, 02:47:11 AM »
I saw this when linear FM was added. I had previously programmed some patches utilizing exponential FM, but after I updated the firmware with the linear FM addition, some of those patches/sequences changed. I haven't bothered to reprogram them yet, and in all fairness, I don't know for sure if that was the cause, but just an observation, and something you might check, if applicable.
DSI Pro 2 | Moog Grandmother | Moog DFAM | Behringer DeepMind 12 | 104 HP Eurorack | Volca Beats/Sample | Ableton Live 9 | Eventide H9 | Boss DD-500 | EHX Grand Canyon | iPad

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #127 on: May 02, 2020, 12:23:42 AM »
Couldn't you try rolling back the firmware, see if the patches revert and then back up before reinstalling the latest firmware?

It could be that certain parameters were given a slightly different location in the code between versions; this would cause differences (but saving probably wouldn’t help anyway).

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #128 on: May 19, 2020, 07:35:59 PM »
Couldn't you try rolling back the firmware, see if the patches revert and then back up before reinstalling the latest firmware?

It could be that certain parameters were given a slightly different location in the code between versions; this would cause differences (but saving probably wouldn’t help anyway).

I can try this. Where do I find older versions of the OS?

Re: Pro 2 BETA 1.4.0.5 Bug reports
« Reply #129 on: May 20, 2020, 04:47:09 AM »
Couldn't you try rolling back the firmware, see if the patches revert and then back up before reinstalling the latest firmware?

It could be that certain parameters were given a slightly different location in the code between versions; this would cause differences (but saving probably wouldn’t help anyway).

I can try this. Where do I find older versions of the OS?

The main sequential website should have the latest official (non-beta) release of the firmware. At the very bottom of this page:
https://www.sequential.com/download-latest-pro-2-os/