The Official Sequential/DSI Forum

MIDI Recording Latency In Logic Pro X

MIDI Recording Latency In Logic Pro X
« on: April 03, 2018, 05:42:36 AM »
New Tempest user here. I am trying to record MIDI notes from Tempest into LPX and when doing this I get a delay between hitting the pad and the note being recorded into LPX by close to a 16th note. I don't observe this behavior with other devices. If I use the tempest pads to play notes on an instrument channel in Logic there is no latency. When I record audio direct there is no Latency.

I have included a picture of this.


RobH

  • ***
  • 464
Re: MIDI Recording Latency In Logic Pro X
« Reply #1 on: April 03, 2018, 06:10:29 AM »
New Tempest user here. I am trying to record MIDI notes from Tempest into LPX and when doing this I get a delay between hitting the pad and the note being recorded into LPX by close to a 16th note. I don't observe this behavior with other devices. If I use the tempest pads to play notes on an instrument channel in Logic there is no latency. When I record audio direct there is no Latency.

I have included a picture of this.

There will be a individual adjustment for each midi device in and out in Logic preferences/options I would think that will solve this problem.

Re: MIDI Recording Latency In Logic Pro X
« Reply #2 on: April 03, 2018, 07:11:43 AM »
There will be a individual adjustment for each midi device in and out in Logic preferences/options I would think that will solve this problem.

Hmm maybe I've just gotten lucky and I've never had to use that with a MIDI instrument before. I'll try and play around with this/figure out how to do this. Thanks!

Re: MIDI Recording Latency In Logic Pro X
« Reply #3 on: April 03, 2018, 03:38:31 PM »
So this is super frustrating.... When I open a new file I can tap in beats with no discernible latency between what I play and MIDI note registered, yet when I try tapping in beats into a an already existing file with stuff recorded in it all ready I'm getting crazy latency... yet when I record the audio of the midi notes I recorded into my daw it lined up perfectly with my grid - here is a photo showing on top the midi notes I recorded (super delayed) and then the audio I got from recording those MIDI notes into logic.

I use MIDI often and I've never had anything like this happen...

I should add - for hooking up Tempest to get Logic to recognize MIDI notes from Tempest I had to set MIDI remote play to channel 1 and logic to record MIDI from channel 1 - is this correct? All of my other keyboards are just plug and play and with Tempest Logic didn't automatically recognize it.

I'm using Main OS version 1.4.5.5
Voice OS version 1.3
Panel OS version 1.3
Sam OS version 1.1
if any of that helps...
« Last Edit: April 03, 2018, 04:22:49 PM by jp973156 »

Re: MIDI Recording Latency In Logic Pro X
« Reply #4 on: April 03, 2018, 05:20:28 PM »
Why or why are you using this OS?Everything before the last OS release is buggy as hell!Download the last Main and Voice OS of Tempest at the bottom of the 1st post here:
https://forum.davesmithinstruments.com/index.php/topic,586.0.html

Re: MIDI Recording Latency In Logic Pro X
« Reply #5 on: April 03, 2018, 06:14:29 PM »
Why or why are you using this OS?Everything before the last OS release is buggy as hell!Download the last Main and Voice OS of Tempest at the bottom of the 1st post here:
https://forum.davesmithinstruments.com/index.php/topic,586.0.html

Awesome Iíll try first thing tomorrow!
I just bought the Tempest last week and didnít even think to update the OS to most recent version as a potential cause of this issue.

Re: MIDI Recording Latency In Logic Pro X
« Reply #6 on: April 04, 2018, 05:04:29 AM »
Just tried updating OS - still have the issue.

1) I tap beat in Logic to metronome in Logic and record MIDI.
2) MIDI notes are delayed by almost 1/4 note in Logic, however
3) MIDI notes play back in correct time
4) If I record the MIDI notes via audio by recording output of tempest into audio track, everything is in time


RobH

  • ***
  • 464
Re: MIDI Recording Latency In Logic Pro X
« Reply #7 on: April 04, 2018, 05:59:36 AM »
I can think maybe you have some kind of loop going where you are recording but also monitoring the midi at the same time. This has happened to me before when I have been live recording and also sending midi to the Tempest with the same track (however this was in Reaper).

Try muting the channel as your recording so itís not sending notes out to the Tempest until you have recorded your notes.

Re: MIDI Recording Latency In Logic Pro X
« Reply #8 on: April 04, 2018, 10:36:12 PM »
I can think maybe you have some kind of loop going where you are recording but also monitoring the midi at the same time. This has happened to me before when I have been live recording and also sending midi to the Tempest with the same track (however this was in Reaper).

Try muting the channel as your recording so itís not sending notes out to the Tempest until you have recorded your notes.
This makes sense!

RobH

  • ***
  • 464
Re: MIDI Recording Latency In Logic Pro X
« Reply #9 on: April 05, 2018, 10:02:05 AM »
I can think maybe you have some kind of loop going where you are recording but also monitoring the midi at the same time. This has happened to me before when I have been live recording and also sending midi to the Tempest with the same track (however this was in Reaper).

Try muting the channel as your recording so itís not sending notes out to the Tempest until you have recorded your notes.
This makes sense!

Somethinng I said on the Tempest forum made sense!!! Finally!!! xD

Re: MIDI Recording Latency In Logic Pro X
« Reply #10 on: April 06, 2018, 10:33:03 AM »
Thanks for all the responses! I found a work around, just in case anyone runs into same project.

1. Instead of using "external MIDI instrument" track, create a new instrument track
2. Select the "external instrument plugin", select Tempest
3. Turn on low latency mode
4. Turn down channel in logic and monitor on your interface (I'm using Apollo Console)

This worked like a charm and allowed me to play and record pads with no latency. I've always used "external MIDI track" option, but whatever, this works fine.

RobH

  • ***
  • 464
Re: MIDI Recording Latency In Logic Pro X
« Reply #11 on: April 06, 2018, 12:11:30 PM »
Thanks for all the responses! I found a work around, just in case anyone runs into same project.

1. Instead of using "external MIDI instrument" track, create a new instrument track
2. Select the "external instrument plugin", select Tempest
3. Turn on low latency mode
4. Turn down channel in logic and monitor on your interface (I'm using Apollo Console)

This worked like a charm and allowed me to play and record pads with no latency. I've always used "external MIDI track" option, but whatever, this works fine.

Ah. So it is 99% that you need to adjust the buffer setting on your soundcard to be lower. This is what can cause the latency you are experiencing, its to do with the audio not the midi.

Re: MIDI Recording Latency In Logic Pro X
« Reply #12 on: April 20, 2018, 06:56:23 AM »
Sounds to me like you have a bunch of plug-ins that are causing latency and Logic is not compensating correctly for some reason, the fact that turning 'low latency mode' on helps seems to confirm this (basically this disables plug-ins that generate latency over a certain amount of samples).

I've never had any issues using the Tempest as a MIDI source for Logic, getting it to sync properly on the other hand has always felt like something of a black art!
Noise, Noodles and Doodles: http://bit.ly/mrjonesthebutcher

Re: MIDI Recording Latency In Logic Pro X
« Reply #13 on: April 23, 2018, 03:54:56 AM »
If i could help, i have  just resolving the problem with my pro tools HD.
Instead of using midi ajustement, i had adjusting each track manually to find the perfect timing with the offset.
Each tracks g-have different plug in , so you must adjust manually the echantillons offset.
It's perhaps long , but the result is a perfect timing between audio and midi.
For example on my kick track, i have -20ms !!!!!! for having a perfect timing.
Hope that could help you.