The Official Sequential/DSI Forum

Midi Problem between Cubase and REV2

Midi Problem between Cubase and REV2
« on: February 18, 2018, 05:31:59 AM »
Hi all !

I'm Robin Notte (yes it's my real name  ;D)  , professional Keyboardist from France.
I have a very boring problem with my REV2
When i use the REV2 as master keyboard to record midi tracks in Cubase, each note is recorded twice, they are stacked.  So When i play the midi track in the REV2 as slave, i makes the REV2 Bug ! No sound comes out from it  until i delete the doubled notes one by one. very boring , it kills the creation !
I use USB cable to go in my DAW

Thanks in advance for helping me

Re: Midi Problem between Cubase and REV2
« Reply #1 on: February 18, 2018, 09:39:12 PM »
You need to turn local off in the Rev 2. Global Parameter 13.
Original Model D <> Sub 37 <> Minitaur <> Slim Phatty <> OB-6 <> Prophet Rev2 8Voice <> Integra 7 <> SE-02 <> Prologue16 <> Triton Le <> Boss Dr. Rhythm DR-55 <> Sound Gizmo

"They're not aliens...they're Americans!"
(The Mouse That Roared, 1959)

Re: Midi Problem between Cubase and REV2
« Reply #2 on: February 19, 2018, 01:17:42 PM »
If i do that, i dont have any sound anymore. I want to play the REV2 as an instrument, record with it and then replay it in MIDI. i have to hear what i play .
What is the strangest in this story, it's that on some tunes, i dont have that problem, it records only one midi information, on other tunes, it records 2 notes at a time . i dont understand , it pisses me off :/

Re: Midi Problem between Cubase and REV2
« Reply #3 on: February 19, 2018, 04:13:40 PM »
You need to turn local off on the REV2 and make sure that Cubase's midi thru is active. I figured it was already active because of the double notes you mentioned. Midi thru can be found in Midi Preferences.
This is how the "Pros" get it done. Honest.

With midi thru active, the midi flows out of the Rev2 into Cubase and is then sent back out to the Rev2.
If local is on you get double notes and all kinds of weird behavior because the midi is essentially in an endless loop. Midi loops are never a good thing. Make sure the Rev2 globals are set up to use usb as well.

« Last Edit: February 19, 2018, 04:15:44 PM by Chimponaut »
Original Model D <> Sub 37 <> Minitaur <> Slim Phatty <> OB-6 <> Prophet Rev2 8Voice <> Integra 7 <> SE-02 <> Prologue16 <> Triton Le <> Boss Dr. Rhythm DR-55 <> Sound Gizmo

"They're not aliens...they're Americans!"
(The Mouse That Roared, 1959)

Re: Midi Problem between Cubase and REV2
« Reply #4 on: February 20, 2018, 10:11:28 AM »
Ok i just found the problem !!!
it's not about the Local off or On, the problem comes with the Stacked sound !  if i record with a single sound, i have one note only, if i record with stacked presets i have 2 notes stacked each time instead of one , i tried with local off and on, it's the same thing !
so now the question is : how can i solve this problem ?




Re: Midi Problem between Cubase and REV2
« Reply #5 on: February 20, 2018, 06:43:03 PM »
Sounds like you've got multimode turned on, and there is something about your midi track setup that is recording midi data for each layer/channel for stacked and split presets.  If you're not building tracks up in a truly bi-timbral way, you don't need to have multimode on.  Turn it off.  Do that, make sure you're on the latest firmware, because there were layer/bi-timbral related issues with early versions of the firmware, make sure you're only using the MIDI Out setting that you have physically wired up to your computer, turn off MIDI monitor on your Cubase track if you don't need it - that could be causing a feedback loop that is causing notes to record twice - and I think that should do it.

Ok i just found the problem !!!
it's not about the Local off or On, the problem comes with the Stacked sound !  if i record with a single sound, i have one note only, if i record with stacked presets i have 2 notes stacked each time instead of one , i tried with local off and on, it's the same thing !
so now the question is : how can i solve this problem ?
« Last Edit: February 20, 2018, 06:45:14 PM by deemadden »

Re: Midi Problem between Cubase and REV2
« Reply #6 on: February 21, 2018, 03:41:43 AM »
you are a GENIUS !!! thanks !! it works ! i turned multimode off and dont have the problem anymore at last ! thank you so much ! i didn't change anything but that and it seems to be alright, i will let you know if something fails but for now it seems ok ! :D