No control of onboard effects when in Cubase


No control of onboard effects when in Cubase
« on: March 29, 2017, 03:12:43 PM »
I'm sure this is a settings issue but I can't figure it out so any help appreciated :-)

I have just one synth - the OB6 Keyboard directly connected my Imac via usb. No other equipment in the mix.

When I switch to local mode everything functions as normal but when using the OB6 in Cubase with local mode off, it does not respond to any changes in the synth's effects. I can switch them on and off or change effect / parameter but the sound does not respond.

Arpeggiator is fine and all other controls seem fine. Sequencer does not play either though.

Global settings as follows:

Midi Out: USB
Midi Sysex: Nid
Midi Control: On
Param Rcv: CC
Param Xmit: CC
Clock port: USB
Midi Clock: Out
Midi Channel: 2
Local Control: OFF

Thanks in advance

Re: No control of onboard effects when in Cubase
« Reply #1 on: March 29, 2017, 06:49:58 PM »
The OB-6 has more parameters than are supported by the basic MIDI CC spec. So only a subset of the OB-6’s parameters can be transmitted or received by MIDI CC. That’s why the OB-6 supports NRPN — it allows for ALL the OB-6 parameters to be sent over MIDI (as well as a greater granularity in those values).

So, in the case of the Effects parameters — these are some of those parameter types that are not sent or received by the OB-6 over MIDI CC. And, by your Global Settings, I see that’s exactly what you’re trying to do. Which is why it's not working.

Now, ‘lest you think you can just turn on NRPN (rather than CC) and be done with it — there is a major caveat: Not every DAW supports NRPN. Ableton Live and Bitwig Studio are two modern and popular DAWs that do not (I don't use and don't know about Cubase).

Also, you mentioned that your sequencer wasn’t working over MIDI. That’s because your MIDI Clock is set to OUT, meaning it can SEND MIDI Clock, but not receive it. You need to set it to “IN”. Or use my preferred value, which is “nSS” — which means that the OB-6 will receive MIDI clock but won’t automatically start playing a sequence the second it “hears” a clock.


Re: No control of onboard effects when in Cubase
« Reply #2 on: March 30, 2017, 12:48:36 AM »
Awesome thanks! I changed Param Rvc and Xmit to nr and all is well again :-)