The Official Sequential/DSI Forum

Prophet 12 Delay problems?

Prophet 12 Delay problems?
« on: January 14, 2017, 06:15:59 PM »
Hi, My first post on here so please be gentle.

Is it just me but occasionaly when i add delay to a patch it sometimes just kills the delay and it will only come back on when I reload the sound, but then the delay disappears again after a few seconds????

It doesn't seem to be with every patch, but is it possible that I am overtaxing the DSP that handles the delay?

As an example, a patch with just one Osc with 4 delays set at say 22, 30, 100 and 140 ms and then an LFO varying the delay time by a small amount. Keeps happening to me.

OS is latest (1.4.1)

can i just say that I bought the Pro 12 after amazing support by the DSI guys when i owned a Mopho and had a problem - it was out of warranty and they told me how to resolve my problem which it did. I then bought a Pro 2 and now a Pro 12!

Re: Prophet 12 Delay problems?
« Reply #1 on: January 15, 2017, 02:03:56 AM »
I seem to remember the delays being a bit buggy in previous releases but thought they fixed it.

I can't test it out at the moment, maybe worth you pinging an email to DSI support.

Re: Prophet 12 Delay problems?
« Reply #2 on: January 16, 2017, 08:09:01 AM »
I remember the delay cutting out on me too - was easy to reproduce if you cranked up the feedback/amount. I had another issue which required me to send the board to DSI:

http://forum.davesmithinstruments.com/index.php/topic,602.msg7052.html#msg7052

I don't remember 100% but I think the delay problem was fixed by replacing the board. Certainly if the OS update didn't work for you then I would suspect it's a board issue.

But yeah talk with DSI support - they're great :-)

Re: Prophet 12 Delay problems?
« Reply #3 on: January 16, 2017, 07:32:32 PM »
Hi, My first post on here so please be gentle.

Is it just me but occasionaly when i add delay to a patch it sometimes just kills the delay and it will only come back on when I reload the sound, but then the delay disappears again after a few seconds????

It doesn't seem to be with every patch, but is it possible that I am overtaxing the DSP that handles the delay?

As an example, a patch with just one Osc with 4 delays set at say 22, 30, 100 and 140 ms and then an LFO varying the delay time by a small amount. Keeps happening to me.

OS is latest (1.4.1)

can i just say that I bought the Pro 12 after amazing support by the DSI guys when i owned a Mopho and had a problem - it was out of warranty and they told me how to resolve my problem which it did. I then bought a Pro 2 and now a Pro 12!

Albert,

I tested my P12, and it exhibits the same behavior as yours. So, it is either a bug or a hardware problem. I am going to report to support and see what they say and cite this post too. Don't know if this matters, but mine is serial number 00035 from the original batch. What is your serial number? That may give some clue if it is hardware or a software bug. I know they do board revisions over time.
« Last Edit: January 16, 2017, 07:38:24 PM by mildwest »

Re: Prophet 12 Delay problems?
« Reply #4 on: January 16, 2017, 09:12:07 PM »

Hi all,

the old delay was kept, you can choose the feedback mode with the 4th softkey, in low it shouldnt overload afaik.

Hope this helps,

Martin3


Re: Prophet 12 Delay problems?
« Reply #5 on: January 17, 2017, 03:46:59 AM »

Hi all,

the old delay was kept, you can choose the feedback mode with the 4th softkey, in low it shouldnt overload afaik.

Hope this helps,

Martin3

Design-wise it shouldn't overload period. Why else would they release it? That sounds like a bug that should be fixed at the very least.

Re: Prophet 12 Delay problems?
« Reply #6 on: January 17, 2017, 09:40:05 AM »

Hi all,

the old delay was kept, you can choose the feedback mode with the 4th softkey, in low it shouldnt overload afaik.

Hope this helps,

Martin3

Design-wise it shouldn't overload period. Why else would they release it? That sounds like a bug that should be fixed at the very least.


Hi all,

could some of you test if this happens in low feedback mode, dont want to do wrong tests here. :)

Thank you,

Martin3

Re: Prophet 12 Delay problems?
« Reply #7 on: January 17, 2017, 06:45:54 PM »

Hi all,

the old delay was kept, you can choose the feedback mode with the 4th softkey, in low it shouldnt overload afaik.

Hope this helps,

Martin3

Design-wise it shouldn't overload period. Why else would they release it? That sounds like a bug that should be fixed at the very least.


Hi all,

could some of you test if this happens in low feedback mode, dont want to do wrong tests here. :)

Thank you,

Martin3

Martin,

Low mode is an improvement 99% of the time. I was only able to make it fail once after multiple tests in low mode. Still seems like a poor design decision to have something in the synth that can fail like that. Why even have a high mode when it chokes out most of the time? Here is the official answer from DSI support:

Thanks for contacting us here at DSI. The issue you are finding with the delays is due to the delay buffer being overloaded. You can see if changing the High/Low parameter in the Delay Mode section changes anything but currently there is a limitation with the DSP on the Prophet 12. I hope this answers your question.

Re: Prophet 12 Delay problems?
« Reply #8 on: January 19, 2017, 07:29:44 AM »

Hi all,

the old delay was kept, you can choose the feedback mode with the 4th softkey, in low it shouldnt overload afaik.

Hope this helps,

Martin3

Design-wise it shouldn't overload period. Why else would they release it? That sounds like a bug that should be fixed at the very least.


Hi all,

could some of you test if this happens in low feedback mode, dont want to do wrong tests here. :)

Thank you,

Martin3

Martin,

Low mode is an improvement 99% of the time. I was only able to make it fail once after multiple tests in low mode. Still seems like a poor design decision to have something in the synth that can fail like that. Why even have a high mode when it chokes out most of the time? Here is the official answer from DSI support:

Thanks for contacting us here at DSI. The issue you are finding with the delays is due to the delay buffer being overloaded. You can see if changing the High/Low parameter in the Delay Mode section changes anything but currently there is a limitation with the DSP on the Prophet 12. I hope this answers your question.

Hi,

so we learned we dont need to reset the synth, switching the feedback mode on and off will revive it. The old delay mode was kept by user request, if you dont like it save your init patches with low feedback mode. Both have their strength i guess.

Happy tweaking all,

Martin3

Re: Prophet 12 Delay problems?
« Reply #9 on: January 30, 2017, 12:38:15 PM »
Thanks all for your suggestions and testing - glad I wasn't the only one. I was beginning to think something was dying but glad it's just a dap overload.

I managed to tweak a few of the patches so the feedback was a bit lower and it helps a lot.

I can live with it now I know it's just a small limitation on an otherwise awesome synth.

Thanks again people!