The Official Sequential/DSI Forum

SEQUENTIAL/DSI => Pro 3 => Topic started by: iluvchiclets on February 28, 2021, 05:56:15 PM

Title: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on February 28, 2021, 05:56:15 PM
Well, here's a weird one.  I would be happy if other Pro3 users could take a moment and see if their synths have the same behaviour.

I notice when I play program F7 P23 (Paraphonic Baroque) it will play differently depending on how I select the program.

- If I select the program P23 by turning the program wheel from either side - P22 (Vintage A.R.P-eggio) or from P24 (Grade School Musical) - it will play fine.

- But, if I physically play program P22 first (Vintage A.R.P-eggio), and then select P23  (Paraphonic Baroque) it will play all "wrong" and sound off.   

I have no idea if this is happening with any other programs, as it would be exhausting to try and find out what programs are playing correct and which are not depending on how they're selected.

Any ideas?  Is the patch corrupted?  Or is it how voices are handled during program changes...?  I tried reloading all the factory patches via sysex and it still occurs...
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: chysn on February 28, 2021, 08:07:00 PM
Can confirm.

Very strange.
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on March 01, 2021, 04:17:19 AM
Thank you for letting me know.   I am hoping it's a "program" problem rather than a "hardware" problem.

(I should also add, when P23 (Paraphonic Baroque) misbehaves, there are two variations of misbehavior.  Most of the time it sounds as if one of the oscillators octave settings has suddenly dropped in pitch.  But occasionally P23 will sound like an out of control distorted, screeching sound. )
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: Quatschmacher on March 01, 2021, 04:44:51 AM
Well, here's a weird one.  I would be happy if other Pro3 users could take a moment and see if their synths have the same behaviour.

I notice when I play program F7 P23 (Paraphonic Baroque) it will play differently depending on how I select the program.

- If I select the program P23 by turning the program wheel from either side - P22 (Vintage A.R.P-eggio) or from P24 (Grade School Musical) - it will play fine.

- But, if I physically play program P22 first (Vintage A.R.P-eggio), and then select P23  (Paraphonic Baroque) it will play all "wrong" and sound off.   

I have no idea if this is happening with any other programs, as it would be exhausting to try and find out what programs are playing correct and which are not depending on how they're selected.

Any ideas?  Is the patch corrupted?  Or is it how voices are handled during program changes...?  I tried reloading all the factory patches via sysex and it still occurs...

Have you reported this to Sequential support? The fact that you can show clear steps to reproduce the bug will help them to diagnose and fix it quicker. 
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on March 01, 2021, 12:11:13 PM
Hi, yes I did report this to them.

I have read a bit about other's programs starting "distorted".  I wonder if this is somehow related.  Perhaps it is how programs are handled with the firmware....?

I'm hoping it can be solved....
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on March 01, 2021, 03:05:02 PM
(Sequential did confirm it's a bug in the OS...)

Hopefully get a fix in a firmware update someday.
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on July 01, 2021, 04:44:24 PM
I just updated to OS 1.1.2.8 and this bug still occurs.  I was hoping that Sequential would have figured this out by now.'

What it makes me wonder is if other programs are unknowingly behaving wrong depending on how they are selected?  I might not realize the glitch, and be missing out on some "nice" patches...
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: thadmcc on July 06, 2021, 07:43:04 PM
Mine (i assume all of ours at this point) does this as well. I just noticed if you switch F7 P22 (Vintage ARP) from trigger mode to Normal mode by pressing the Mode button once, then F7 P23 (Paraphonic Baroque, the original patch in question from the OP) will play as intended and not that weird messed up sound.   I don't know why, but it seems like the Trigger setting on P22 is what's causing the problem as if it is still lingering into the next patch. but there's a solution for now: swith P22 into Normal mode if you want to go to P23 and have it sound correct
Title: Re: Weird Program Behaviour - Dependent on How Patches are Switched...!?
Post by: iluvchiclets on July 09, 2021, 06:22:46 PM
That's a great idea....Thanks!  I guess I could see if other programs with "trigger" mode affect other programs that reside beside them. 

(Or is it the two program's arp modes that are conflicting...?)