The Official Sequential/DSI Forum

Rev 2 Problem

Rev 2 Problem
« on: January 03, 2021, 03:19:15 AM »
Hi all,
I have recently bought a rev2 and loved it until today!
I am new to the Sequential/DSI world and a new forum member. So go easy on me.

The problem I have with my rev2 is in the Global menu it goes from...
16) Local control
to
19) Mono/Stereo
...missing out access to the parameters I want to edit. Where are 18 and 19?

I realise this is probably not the right place to ask. But can someone please help? It is driving me insane!

Re: Rev 2 Problem
« Reply #1 on: January 03, 2021, 09:05:18 AM »
Weird...those 2 missing parameters deal with velocity and aftertouch curves. Is this a desktop module?

Re: Rev 2 Problem
« Reply #2 on: January 03, 2021, 07:59:40 PM »
if memory serves me right, I think I read in the manual that velocity and after touch curve settings do not effect how external keyboards send velocity and after touch to the Rev 2. If it's a module and not the keyboard version, it would make sense that these features are omitted. I believe you would have to set that up on your master keyboard.

Re: Rev 2 Problem
« Reply #3 on: January 03, 2021, 11:04:49 PM »
Weird...those 2 missing parameters deal with velocity and aftertouch curves. Is this a desktop module?
Hi thanks for the reply, Yes it is the desktop module. The setting I am trying to change is...

 "17 .  Pot Mode:  Relative, Passthru, Jump"
(according to the manual)

That should be on the module version.


Re: Rev 2 Problem
« Reply #4 on: January 03, 2021, 11:17:30 PM »
if memory serves me right, I think I read in the manual that velocity and after touch curve settings do not effect how external keyboards send velocity and after touch to the Rev 2. If it's a module and not the keyboard version, it would make sense that these features are omitted. I believe you would have to set that up on your master keyboard.

Hi,
Thanks for the reply.

The setting I want to change is "17 .  Pot Mode:  Relative, Passthru, Jump"

I don't really see why that wouldn't be available on the module.

It is 17 and 18 missing.

Also 27 and 28 are missing when you go down the list. But only 27 is missing when I go up the list. (Now that is odd!)

This is so frustrating.

I was wondering if there is a reset or something I can try? Any ideas?


Re: Rev 2 Problem
« Reply #5 on: January 04, 2021, 01:20:59 AM »
if memory serves me right, I think I read in the manual that velocity and after touch curve settings do not effect how external keyboards send velocity and after touch to the Rev 2. If it's a module and not the keyboard version, it would make sense that these features are omitted. I believe you would have to set that up on your master keyboard.

Hi,
Thanks for the reply.

The setting I want to change is "17 .  Pot Mode:  Relative, Passthru, Jump"

I don't really see why that wouldn't be available on the module.

It is 17 and 18 missing.

Also 27 and 28 are missing when you go down the list. But only 27 is missing when I go up the list. (Now that is odd!)

This is so frustrating.

I was wondering if there is a reset or something I can try? Any ideas?

You were correct all along I think!

I am reading from manual v1.0...  That is out of date. 20. Is the potentiometer behaviour.

Sorry for wasting everyone's time.

Maybe Google needs to be pointed at the more modern manual. I had a more modern manual download somewhere. Just could not find it. Latest is v1.2.3, Google points at v1.0

Cheers

Re: Rev 2 Problem
« Reply #6 on: January 04, 2021, 01:26:16 AM »
if memory serves me right, I think I read in the manual that velocity and after touch curve settings do not effect how external keyboards send velocity and after touch to the Rev 2. If it's a module and not the keyboard version, it would make sense that these features are omitted. I believe you would have to set that up on your master keyboard.

Turns out I had an old version of the manual. (v1. 0) Followed Google! Potentiometer behaviour is now number 20. in the that menu, not 17.
All is good with the instrument, it is just me being a numpty.
Thanks for the help anyway.
Cheers.

Re: Rev 2 Problem
« Reply #7 on: January 04, 2021, 01:42:15 AM »
To see if I was going mad I went back and checked.
In the "global" menu.
My rev 2 module goes...
25. 26. 27. 29. 30.
But in the other direction it goes...
30. 29. 26. 25.

So it misses out "27. Save Edit B" in one direction!

I think I may have stumbled across a bug in 1.1.5.9

Can anyone with a rev 2 module confirm?
« Last Edit: January 04, 2021, 02:09:46 AM by Eric Blair »

bax

Re: Rev 2 Problem
« Reply #8 on: January 08, 2021, 07:09:01 AM »
To see if I was going mad I went back and checked.
In the "global" menu.
My rev 2 module goes...
25. 26. 27. 29. 30.
But in the other direction it goes...
30. 29. 26. 25.

So it misses out "27. Save Edit B" in one direction!

I think I may have stumbled across a bug in 1.1.5.9

Can anyone with a rev 2 module confirm?

Ha!!! Good catch, yes I can confirm the same (repeatable) behaviour here. REV2 Desktop 16voice running 1.1.5.9

Thanks!
bax

EDIT: Eric, I just added your observations and description to the official Bug Thread.
« Last Edit: January 08, 2021, 07:27:58 AM by bax »

Re: Rev 2 Problem
« Reply #9 on: January 12, 2021, 04:16:12 PM »
To see if I was going mad I went back and checked.
In the "global" menu.
My rev 2 module goes...
25. 26. 27. 29. 30.
But in the other direction it goes...
30. 29. 26. 25.

So it misses out "27. Save Edit B" in one direction!

I think I may have stumbled across a bug in 1.1.5.9

Can anyone with a rev 2 module confirm?

Ha!!! Good catch, yes I can confirm the same (repeatable) behaviour here. REV2 Desktop 16voice running 1.1.5.9

Thanks!
bax

EDIT: Eric, I just added your observations and description to the official Bug Thread.

Thank you for confirming. I can easily understand how this one got overlooked by the software developers.