The Official Sequential/DSI Forum

Daw = Loosing voices

Daw = Loosing voices
« on: July 13, 2019, 05:52:28 PM »
When i create a midi track in my DAW, suddenly the rev2 only handle 4 voices... sometimes less..Also it will automatically transpose a whole step.

Also when I set the rev2 to slave mode, the sequencer and arp functions do not work...

I can't figure this out. :'(

Re: Daw = Loosing voices
« Reply #1 on: July 13, 2019, 11:22:53 PM »
Sounds like you have a midi loop and the clock isnít being receive. Fornthe midi loop youíll have to EITHER use local control OR turn it off and use midi control. Whatís happening is the rev two is locally triggering a voice AND your sending midi to it via the LB to the DAW then back to the Rev 2 so every note is being double triggered, seeming as though itís only using half the voices.

As for the rap/sequencer I assume itís not receiving clock. Go to globals and make sure the midi clock is set to slave (probably slave no S/S actually) and that the MIDI cable setting is set to eithe USB or Midi (depending on which one youíre using). I donít have my Rev 2 near me so I may have gotten some of the exact wording off but it should be clear what I was saying when you look through your globals. Also, youíll know youíre getting clock if the top right of the Rev 2 screen shows the tempo/BPM and that tempo/BPM changes when you change your daw tempo/BPM. If itís not receiving it there will just be a dash.

If that doesnít clear it up then itís in your daw and is perhaps some sort of ďsyncĒ not being turned on. I personally am only very familiar with ableton but if this doesnít work perhaps state the DAW and itíll help clear it up.

Razmo

  • ***
  • 1880
  • I am shadow...
    • Kaleidoscopic Artworks
Re: Daw = Loosing voices
« Reply #2 on: July 14, 2019, 12:55:47 AM »
Half the voices usually mean that you have forgotten to set your REV2 to be "Local Off", and at the same time are echoing the MIDI data your DAW is recieving from the REV2, back to the REV2... then what happens is that it plays one note when you hit a key on REV2, but also send that note to your DAW that then sends it back to your REV2 via MIDI, and play that same note once again... every note you play is played twice on top of each other... thus half the polyphony... if you set your REV2 to be "Local Off" (you can find that parameter in the global settings) you disable the keys on REV2 from the engine... thus it will only play the note it recieves back via MIDI... problem solved.

If Slave mode is set, then your REV2 will not work with either ARP or Sequencer or any tempo sync function, unless it also recieve MIDI Clock messages on the MIDI input... you DAW is supposed to send that clock, so enter your DAW's MIDI settings, and make sure it is sending MIDI clock.
« Last Edit: July 14, 2019, 12:58:51 AM by Razmo »
If you need me, follow the shadows...